Bug 435926 - [PATCH] create proper device nodes for cdrom in rescue mode
[PATCH] create proper device nodes for cdrom in rescue mode
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.9
All Linux
medium Severity low
: rc
: ---
Assigned To: Chris Lumens
Release Test Team
:
Depends On:
Blocks: 391511 409961
  Show dependency treegraph
 
Reported: 2008-03-04 09:27 EST by Adam Stokes
Modified: 2010-10-22 18:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 17:06:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
allow cdrom creation in rescue mode (507 bytes, patch)
2008-03-04 09:27 EST, Adam Stokes
no flags Details | Diff

  None (edit)
Description Adam Stokes 2008-03-04 09:27:54 EST
Description of problem:
When starting the system with rescue mode using the installation CD for RHEL4.x,
/dev/hdx (for DVD-RAM drive) is not made.

Version-Release number of selected component (if applicable):
10.1.1.81

How reproducible:
100%

Steps to Reproduce:
1. boot into rescue mode
2. attempt to access cdrom
3.
  
Actual results:
cdrom not accessible until after creating block file

Expected results:
cdrom is accessible

Additional info:
Comment 1 Adam Stokes 2008-03-04 09:27:54 EST
Created attachment 296738 [details]
allow cdrom creation in rescue mode
Comment 2 Chris Lumens 2008-07-28 15:19:26 EDT
I think a slightly better way of doing this patch would be to call
isys.flushDriveDict in rescue.py immediately before makeDriveDeviceNodes.  That
would mean less random device probing/opening/closing in the regular install case.
Comment 4 RHEL Product and Program Management 2008-10-02 06:36:36 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Chris Lumens 2008-11-19 13:39:41 EST
This should be fixed in anaconda-10.1.1.92-1.
Comment 7 Alexander Todorov 2009-02-17 08:03:39 EST
Chris,
I've tried this with Xen FV guest and the only device nodes in rescue mode are /dev/hda* where /dev/hda is the hard drive of the system. No sign of /dev/hdc which is supposed to be the CDROM drive. This was with anaconda-10.1.1.96-1. Is it supposed to work under Xen or I need physical machine to test it?
Comment 9 Jan Stodola 2009-04-21 09:52:23 EDT
Tested with RHEL4-U8-re20090416.0-x86_64-AS (anaconda-10.1.1.103-1) on physical machine and node for CDROM drive is still missing in /dev directory.
Comment 10 Chris Lumens 2009-04-22 15:38:46 EDT
Having examined the code again, it looks like I should have applied the original patch instead of doing one up myself.  I'll back out what I did, apply the first patch, and push.
Comment 11 Chris Lumens 2009-04-22 15:42:36 EDT
This will be fixed in anaconda-10.1.1.104-1.
Comment 14 Denise Dumas 2009-04-23 09:28:34 EDT
moving to 4.9 since RC already built
Comment 15 Alexander Todorov 2009-04-24 10:57:05 EDT
(In reply to comment #14)
> moving to 4.9 since RC already built  

Can we remove this bug from the advisory since moved to 4.9?
Comment 17 David Cantrell 2010-07-01 17:01:25 EDT
anaconda is not an approved component for RHEL 4.9 since we are not generating new media, this bug should not be in MODIFIED because there is no new anaconda available.

Note You need to log in before you can comment on or make changes to this bug.