Bug 435935 - SELinux is preventing vbetool (vbetool_t) "mmap_zero" to <Unknown> (vbetool_t).
SELinux is preventing vbetool (vbetool_t) "mmap_zero" to <Unknown> (vbetool_t).
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Daniel Walsh
:
: 435198 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-04 10:03 EST by Eduard Benes
Modified: 2008-05-21 12:07 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0465
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:07:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduard Benes 2008-03-04 10:03:20 EST
Setroubleshoot reports this alert after the machine resumes from suspend.

Summary:

SELinux is preventing vbetool (vbetool_t) "mmap_zero" to <Unknown> (vbetool_t).

Detailed Description:

SELinux denied access requested by vbetool. It is not expected that this access
is required by vbetool and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:vbetool_t
Target Context                system_u:system_r:vbetool_t
Target Objects                None [ memprotect ]
Source                        vbetool
Source Path                   /usr/sbin/vbetool
Port                          <Unknown>
Host                          dhcp-lab-118.englab.brq.redhat.com
Source RPM Packages           pm-utils-0.99.3-6.el5.18
Target RPM Packages           
Policy RPM                    selinux-policy-2.4.6-121.el5
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     dhcp-lab-118.englab.brq.redhat.com
Platform                      Linux dhcp-lab-118.englab.brq.redhat.com
                              2.6.18-83.el5 #1 SMP Thu Feb 21 12:14:23 EST 2008
                              i686 i686
Alert Count                   3
First Seen                    Tue Mar  4 15:25:09 2008
Last Seen                     Tue Mar  4 15:46:00 2008
Local ID                      85911c78-7fdb-43a1-914a-51afccbf288b
Line Numbers                  

Raw Audit Messages            

host=dhcp-lab-118.englab.brq.redhat.com type=AVC msg=audit(1204641960.480:24): 
avc:  denied  { mmap_zero } for  pid=8225 comm="vbetool" 
scontext=system_u:system_r:vbetool_t:s0 tcontext=system_u:system_r:vbetool_t:s0 
tclass=memprotect

host=dhcp-lab-118.englab.brq.redhat.com type=SYSCALL 
msg=audit(1204641960.480:24): arch=40000003 syscall=192 success=no exit=-13 
a0=0 a1=502 a2=7 a3=11 items=0 ppid=8220 pid=8225 auid=4294967295 uid=0 gid=0 
euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 
comm="vbetool" exe="/usr/sbin/vbetool" subj=system_u:system_r:vbetool_t:s0 
key=(null)
Comment 1 Daniel Walsh 2008-03-04 15:49:06 EST
Fixed in selinux-policy-2.4.6-124.el5	
Comment 2 RHEL Product and Program Management 2008-03-04 16:08:30 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Daniel Walsh 2008-03-05 16:11:50 EST
*** Bug 435198 has been marked as a duplicate of this bug. ***
Comment 9 errata-xmlrpc 2008-05-21 12:07:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0465.html

Note You need to log in before you can comment on or make changes to this bug.