Bug 435959 - Chile is going to change time from CLST to CLT on March 29, 2008, instead of March 9, 2008
Chile is going to change time from CLST to CLT on March 29, 2008, instead of ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tzdata (Show other bugs)
4.6
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Petr Machata
http://www.horaoficial.cl/cambio.htm
:
Depends On:
Blocks: 436012 436013 436014
  Show dependency treegraph
 
Reported: 2008-03-04 12:18 EST by Marcelo Giles
Modified: 2015-05-04 21:33 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHEA-2008-0185
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 10:55:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for this problem. (645 bytes, patch)
2008-03-04 16:20 EST, Petr Machata
no flags Details | Diff
Another patch that only made change for this year (2.29 KB, patch)
2008-03-07 09:07 EST, Need Real Name
no flags Details | Diff

  None (edit)
Description Marcelo Giles 2008-03-04 12:18:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.12) Gecko/20080213 Red Hat/1.5.0.12-11.el5_1 Firefox/1.5.0.12

Description of problem:
On March 29, 2008, as per an official decree (Decreto Supremo NĀ° 316, del 8 de febrero de 2008), Chile is going into winter time, intead of historical change on March 9.

# date
Tue Mar  4 13:25:29 CLST 2008
# date -d "now + 5 days"
Sun Mar  9 12:25:39 CLT 2008

This change from CLST to CLT should occur on March 29, 2008 at 24:00, instead of March 10 at 23:00, 2008.

So the tzdata pkg should have this change implemented *before* March 9, 2008.



Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.

Actual Results:


Expected Results:


Additional info:
See also:

http://www.timeanddate.com/worldclock/timezone.html?n=232
Comment 1 Issue Tracker 2008-03-04 12:34:12 EST
This event sent from IssueTracker by mgiles 
 issue 167229
Comment 2 Issue Tracker 2008-03-04 13:10:28 EST
Update on issue:
This is how time change is currently configured (before gvmnt decree):

Saturday, March 8, 2008 at 11:59:59 PM	1 hour	-3 hours	CLST	 
Saturday, March 8, 2008 at 11:00:00 PM	No	-4 hours	CLT

This is how it should be changed (after gvmnt decree):

Saturday, March 29, 2008 at 11:59:59 PM	1 hour	-3 hours	CLST	 
Saturday, March 29, 2008 at 11:00:00 PM	No	-4 hours	CLT

Source:
http://www.timeanddate.com/worldclock/timezone.html?n=232



This event sent from IssueTracker by mgiles 
 issue 167229
Comment 4 Issue Tracker 2008-03-04 16:06:09 EST
Update on issue:
The change requested, so far, is for Continental Chile and Antarctica
only.

On the same date, but at a different time, there has to be a change for
Easter Island and Salas y Gomez Island, too as follows:

Saturday, March 29, 2008 at 9:59:59 PM	1 hour	-5 hours	EASST	 
Saturday, March 29, 2008 at 9:00:00 PM	No	-6 hours	EAST

Source:
http://www.timeanddate.com/worldclock/timezone.html?n=914

# date
Tue Mar  4 15:54:43 EASST 2008
# date -d "now + 5 days"
Sun Mar  9 14:54:46 EAST 2008


This event sent from IssueTracker by mgiles 
 issue 167229
Comment 5 Petr Machata 2008-03-04 16:20:23 EST
Created attachment 296808 [details]
Fix for this problem.

Upstream has been notified 11/Feb but shows no activity since then.  I attach
my stab at the problem.  It transitions Sat Mar 29 23:59:59 -> 23:00:00.  I
made it a permanent rule (i.e. it's scheduled also for following years), but
actually have no idea what's in plan.  Do you know anything closer?
Comment 6 Petr Machata 2008-03-04 16:33:14 EST
I forgot to attach Antarctica in the patch, but have it handy.

Easter Island and Salas y Gomez Island are both Pacific/Easter and use the rules
of continental Chile.  They transition as follows under the patched tzdata:
Sat Mar 29 21:59:59 2008 -> 21:00:00
Comment 7 Marcelo Giles 2008-03-04 17:04:36 EST
Regarding question in Comment #5, AFAIK, the government of Chile did this change
to extend DST due to severe draughts in their country (thus affecting hydraulic
power generation). 

So maybe this change will not be permanent, probably next year they will get
back to "normal" DST changes.

Saturday, March 14, 2009 at 11:59:59 PM	1 hour	-3 hours	CLST	 
Saturday, March 14, 2009 at 11:00:00 PM	No	-4 hours	CLT

Source:
http://www.timeanddate.com/worldclock/timezone.html?n=232
Comment 8 Petr Machata 2008-03-04 17:44:54 EST
Thanks, but unfortunately I've just started spinning a build.  I guess it's not
a problem, official tzdata upstream is probably to appear shortly, and we will
rebase many times before next year.
Comment 11 Need Real Name 2008-03-07 09:07:59 EST
Created attachment 297184 [details]
Another patch that only made change for this year

http://thread.gmane.org/gmane.comp.time.tz/2089/focus=2094
Comment 14 Marcelo Giles 2008-03-07 14:51:35 EST
Petr Machata has already built the packages with the updated time zone data.
Unfortunately, there was no time to upload them to the Red Hat Network (RHN)
servers in time for the change so, as a convenience, Petr has kindly made the
packages available at the following URLs until they're availabe as errata on RHN:

http://people.redhat.com/~pmachata/tzdata/2.1/
http://people.redhat.com/~pmachata/tzdata/3/
http://people.redhat.com/~pmachata/tzdata/4/
http://people.redhat.com/~pmachata/tzdata/5/
Comment 15 Andres Pereira 2008-03-08 12:43:19 EST
Official tzdata upstream[1] has published new timezone files. 

Are you going to wait until tzdata2008b.tar.gz appears in order to release a new
RPM package or just use tzdata2008a.tar.gz?

[1] http://article.gmane.org/gmane.comp.time.tz/2102
Comment 16 Petr Machata 2008-03-08 12:56:22 EST
I don't think there is a reason to go with official upstream.  If I'm reading
the mailing list correctly, the only proposed changes were Chile, or commentary,
or code.  The first one is covered in our package, the other two are not
interesting for tzdata package.  We will wait for 2008b, or whichever next
version brings in important changes.
Comment 18 errata-xmlrpc 2008-03-10 10:55:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0185.html

Note You need to log in before you can comment on or make changes to this bug.