Bug 435962 - [b43] Several kernel oopses with 2.6.24-17.fc8
[b43] Several kernel oopses with 2.6.24-17.fc8
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-04 12:26 EST by Dario Castellarin
Modified: 2008-03-05 13:03 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.24.3-18.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 13:03:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel log dump concernig the oopses (67.89 KB, text/plain)
2008-03-04 12:26 EST, Dario Castellarin
no flags Details

  None (edit)
Description Dario Castellarin 2008-03-04 12:26:03 EST
Description of problem:
On my laptop Dell Inspiron 1501, a series of oopses apparently caused by
mac80211 caused a hard lock.


Version-Release number of selected component (if applicable):
kernel-2.6.24.3-17.fc8

How reproducible:
Pretty much random...

Additional info:
I use the b43 driver on a BCM4312 device, with firmware 410.2160.
Attaching the relative log dumps.
Comment 1 Dario Castellarin 2008-03-04 12:26:03 EST
Created attachment 296770 [details]
kernel log dump concernig the oopses
Comment 2 John W. Linville 2008-03-04 13:52:43 EST
Michael, this kernel has the equivalent wireless bits to the rawhide kernel 
described in bug 435958.  It looks like a similar issue to me.  Have you seen 
anything like this?
Comment 3 John W. Linville 2008-03-04 13:53:36 EST
Dario, what was the last kernel working for you?
Comment 4 Michael Buesch 2008-03-04 14:04:07 EST
yes this seems similiar.

Note that it first faults in ieee80211_key_free() and then throws WARN_ON() on
access of the key struct.
Maybe this is related to the locking changes (rcu-ification) made to that code?
Key refcounting bug?
Comment 5 Johannes Berg 2008-03-04 14:12:43 EST
Please try this patch:

http://thread.gmane.org/gmane.linux.kernel.wireless.general/12036

johannes
Comment 6 Dario Castellarin 2008-03-04 17:48:28 EST
(In reply to comment #3)
> Dario, what was the last kernel working for you?

Prior to this, I was using 2.6.24-13 without particular issues.
Comment 7 Dario Castellarin 2008-03-05 10:42:53 EST
I've been using kernel 2.6.24-18 for some hours now and this problem didn't come
up. Usually system was locking withing 10 minutes from boot so I guess we can
say this bug is solved...
Comment 8 John W. Linville 2008-03-05 13:03:57 EST
Closing based on comment 7 -- thanks to Johannes and Michael for the advice!

Note You need to log in before you can comment on or make changes to this bug.