Bug 435992 - thinkfinger returns two extra <CR> after authenticating
Summary: thinkfinger returns two extra <CR> after authenticating
Keywords:
Status: CLOSED DUPLICATE of bug 356921
Alias: None
Product: Fedora
Classification: Fedora
Component: thinkfinger
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Douglas E. Warner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-04 19:28 UTC by Ulrich Drepper
Modified: 2008-12-21 15:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-12-21 15:15:30 UTC


Attachments (Terms of Use)

Description Ulrich Drepper 2008-03-04 19:28:23 UTC
Description of problem:
I file this as an pam bug since I think this is where it is although su exhibits
the problem.

This is on a rawhide machine, updated via yum from F8.  I already used
thinkfinger before (it's an X61).  Now su does not accept passwords anymore,
only fingerprints.  When I enter a password the following happens:

$ su
Password or swip finger:


su: incorrect password
$
$
$

I.e., I press <return> and somehow two additional return events are created. 
Then the message is printed and the effects of all three returns are felt by the
shell.  Hence the two empty shell command lines above.

Version-Release number of selected component (if applicable):
pam-0.99.10.0-3
coreutils-6.10-9

How reproducible:
always

Steps to Reproduce:
1.start su
2.type in password
3.
  
Actual results:
password fails, strange console interaction described above

Expected results:
password accepted

Additional info:

Comment 1 Tomas Mraz 2008-03-04 20:06:16 UTC
I suppose that it is a bug in the thinkfinger PAM module. What is the contents
of your /etc/pam.d/su and /etc/pam.d/system-auth? And if you remove the
pam_thinkfinger.so module from the PAM configuration does su behave normally?


Comment 2 Ulrich Drepper 2008-03-04 21:10:11 UTC
OK, I tried removing the line.  It didn't work.  But this lead me to
regenerating the password and now it works as expected.  Very strange, the
update shouldn't have changed the password.

Anyway, adding back thinkfinger I see now that the password is accepted but that
the two additional returns are still added.  I.e., it looks like this:

$ su
Password or swipe finger:


$
$
$


I used the password in this case (sometimes there is also only a single
additional return).  When I use the fingerprint itself all works as expected.

Changing component to thinkfinger.

Comment 3 Bug Zapper 2008-05-14 05:46:20 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Noel J. Bergman 2008-12-21 12:57:34 UTC
For what it is worth, this is a duplicate of Bug 356921.

Comment 5 David Nalley 2008-12-21 15:15:30 UTC

*** This bug has been marked as a duplicate of bug 356921 ***


Note You need to log in before you can comment on or make changes to this bug.