Bug 43601 - INN won't start even after running makehistory
Summary: INN won't start even after running makehistory
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: inn   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-05 18:52 UTC by Wouter Liefting
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-20 18:53:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wouter Liefting 2001-06-05 18:52:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (Win95; I)

Description of problem:
Vanilla RH7.1 install. Trying to start innd with service innd start. Won't work, says "run makehistory and/or makedbz". Tried that with several 
variations - doesn't work.
Bugzilla bug 27421 won't fix this.

How reproducible:
Always

Steps to Reproduce:
1.Vanilla 7.1 install
2.service innd start
3.
	

Actual Results:  Please run makehistory and/or makedbz before starting innd.

Expected Results:  INN started

Additional info:

Only on RH7.1. RH7.0 is not affected. Temporary workaround is to install INN from RH7.0

Comment 1 angus young 2001-06-14 18:24:42 UTC
Have the same problem.
Need Help

Comment 2 Henri Schlereth 2001-06-20 18:53:42 UTC
Additional update: I followed the instructions in the NEWS file for makehistory
and makedbz and
inn will now start.

Comment 3 Florian La Roche 2001-06-29 09:18:18 UTC
INN is now much more flexable on how news articels can be stored and before
starting a news-server you have to change the configuration for this.
Please look into the news file for more information.

Thanks,

Florian La Roche


Comment 4 Justin Albstmeijer 2001-07-25 10:06:31 UTC
Could there be some more info on getting this to work.

An example?

Comment 5 Justin Albstmeijer 2001-07-25 11:20:27 UTC
Doing the following solved my startup problem:

edit /etc/news/inn.conf:

changed organization
added pathhost: localhost

touch /var/lib/news/history
makedbz -i
cd /var/lib/news
mv history.n.dir history.dir
mv history.n.hash history.hash
mv history.n.index history.index
chmod 664 history.*



Comment 6 Justin Albstmeijer 2001-07-25 11:25:25 UTC
chown news.news history*


Note You need to log in before you can comment on or make changes to this bug.