Bug 436073 - Requires: gtk+-2.0 missing from WebKitGtk.pc
Requires: gtk+-2.0 missing from WebKitGtk.pc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: WebKit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 02:56 EST by Mamoru TASAKA
Modified: 2008-03-05 16:27 EST (History)
0 users

See Also:
Fixed In Version: 1.0.0-0.7.svn30667
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 16:27:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2008-03-05 02:56:58 EST
Description of problem:
Hi:

Again when I was compiling kazehakase,
------------------------------------------------------------------------
In file included from /usr/include/webkit/webkit.h:23,
                 from kz-webkit-gtk.h:25,
                 from kz-webkit-gtk.c:24:
/usr/include/webkit/webkitdefines.h:23:18: error: glib.h: No such file or directory
-------------------------------------------------------------------------

Some headers in WebKit-gtk-devel requires
header files in gtk2-devel (see webkit/webkitwebview.h)
however WebKitGtk.pc says:
-------------------------------------------------------------------------
prefix=/usr
exec_prefix=/usr
libdir=/usr/lib
includedir=/usr/include/webkit
qt_config=lex yacc uic resources release incremental link_prl no_mocdepend
release stl qt_no_framework gtk-port building-libs no_batch link_pkgconfig x11
hide_symbols link_pkgconfig create_pc create_prl x11lib x11inc dll

Name: Webkitgtk
Description: Webkitgtk Library
Version: 1.0.0
Libs: -L${libdir} -lWebKitGtk
Cflags:  -I${includedir}
-------------------------------------------------------------------------
and WebKitGtk.pc does not require gtk+-2.0.

Version-Release number of selected component (if applicable):
WebKit-gtk-devel-1.0.0-0.6.svn30667.fc9

How reproducible:
100%

Steps to Reproduce:
1. create TEMP.c as
--------------------------------------------------------------------------
#include <webkit/webkitwebview.h>

int main()
{
	webkit_web_view_can_cut_clipboard((WebKitWebView*) 0);
	return 0;
}
---------------------------------------------------------------------------
2. gcc -o TEMP TEMP.c `pkg-config --cflags WebKitGtk` `pkg-config --libs WebKitGtk`
3.
  
Actual results:
$ LANG=C gcc -o TEMP TEMP.c `pkg-config --cflags WebKitGtk` `pkg-config --libs
WebKitGtk`
In file included from TEMP.c:1:
/usr/include/webkit/webkitwebview.h:24:21: error: gtk/gtk.h: No such file or
directory
In file included from /usr/include/webkit/webkitwebview.h:27,
                 from TEMP.c:1:
/usr/include/webkit/webkitdefines.h:23:18: error: glib.h: No such file or directory
...........

Expected results:
Like this:
$ LANG=C gcc -o TEMP TEMP.c `pkg-config --cflags WebKitGtk gtk+-2.0` `pkg-config
--libs WebKitGtk gtk+-2.0`
$


Additional info:
I have not checked WebKit code, so I don't know where WebKitGtk.pc
is created, however WebKit/gtk/webkit.pc.in actually contains
Requires: gtk+-2.0 ?? (however this file contains wrong includedir...)
Comment 1 Mamoru TASAKA 2008-03-05 03:19:19 EST
Note:
for now I manually adds gtk+-2.0 to CFLAGS and LDFLAGS
to compile kazehakase, and with this kazehakase actually compiles

http://koji.fedoraproject.org/koji/taskinfo?taskID=493370
http://koji.fedoraproject.org/koji/taskinfo?taskID=493372

So please don't remove latest WebKit from F-8/7 buildroot.
Comment 2 Peter Gordon 2008-03-05 12:32:38 EST
Hmm, I really need to figure out how that pkgconfig file gets created, since the
webkit.pc.in seems to be only used for the autotools-based build.

In either case, I've committed a workaround to CVS (rawhide) which should fix
the issue for the time-being. It's building in Koji now and should hit
tomorrow's rawhide push. 

Thanks for the bug report! :)

Note You need to log in before you can comment on or make changes to this bug.