Bug 43608 - kpackage corrupted rpm database when removing packages
Summary: kpackage corrupted rpm database when removing packages
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-05 20:13 UTC by Jeff Woods
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-05 20:13:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Woods 2001-06-05 20:13:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-SGI_XFS_1.0 i686)

Description of problem:
Used kpackage to remove a number (> 20) packages at one time.  It
segfaulted and left rpm database in an unstable state.  Now no rpm
utilities seem to work properly (all segfault).  I have tried "rpm
--rebuilddb" without luck.

How reproducible:
Didn't try

Steps to Reproduce:
I have not been able to repair my rpm database for further testing, and
would be reluctant to try to reproduce the bug if I could.  Could this be
confirmed elsewhere?
1.  I loaded kpackage, and selected approximately 20 packages to uninstall.
2.  I selected "Uninstall" and used default options.
3.  kpackage segfaulted and left rpm database in an unstable state.


Additional info:

I am using the RedHat 7.1 standard installation of the kdebase-2.1.1
package with an unmodified kpackage.

Comment 1 Bernhard Rosenkraenzer 2001-07-30 13:08:12 UTC
Can't reproduce this on 5 different machines with the current version, 
assuming it's fixed.



Note You need to log in before you can comment on or make changes to this bug.