Bug 43610 - BitchX is obnoxious in behaviour and language
BitchX is obnoxious in behaviour and language
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: BitchX (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-05 16:16 EDT by Telsa Gwynne
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-17 09:59:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 2001-06-05 16:16:50 EDT
Description of Problem:

I know I'm going to get flamed for this, or accused of having no sense
of humour, but I think this is just obnoxious. I wouldn't have a problem
if it were in source, in comments, in something the user doesn't normally
see. But these are all things which bite the "put CD in drive, installed
RH, away we go" user. Some of it, s/he won't know about until someone
takes pity and tells them. I don't like programs which mock their users.

Start it up and your default "name" (which other IRC users see)
is "I'm to lame to read BitchX docs" instead of the /etc/passwd entry.
How witty. What a funny joke on the user using your software.

Quit and don't give it a quit message and you generate a random quit
message to the rest of the channel. The contents of the file containing
the random messages range from "user abortion with 5 coathooks" to "nice
shoes, wanna fuck?". The way to stop this, according to the docs, is to
delete that file and replace it with something nicer. It's a system file.
Just randomly deleting files from /usr/lib (is that FHS-compliant? It's
a plain ascii file: shouldn't it be in /usr/share somewhere? ircii moved
a lot of stuff there...) is not an option for people without the root
password, and nothing tells them how to create a file that is read
instead of it.

You don't even know you're -sending- such messages. There are channels
some of them won't be appreciated on. I recently pasted someone's /quit
message to them when they returned and they were appalled and embarrassed.
It's not that I find them objectionable. Well, I do. Although in my case
it's not the content: it's the spelling and grammar. Urgh! But that's not
the point. It's the fact people don't even know they are trailing these
messages behind them.

Look in /help and you have the remarkably mature commands "/fuck" and
"/shit", among others. I've seen people complain about xboing's user-
visible strings: well, these and the others I didn't list are even more
likely to generate complaints from some quarters. Yes, I laughed at the
idea that "rude" words should be purged from the kernel, but most people
don't read that. People are a little more likely to read the help for an
IRC client.

Start it in gnome-terminal (which I presume is RH's expectation that
most users will do, and it does Evil Things: the colours are vile, and
the characters are all messed up on the big banner at the top. This is
particularly marked if you have set anything such as transparent
terminal in gnome-terminal. On quitting, it has supremely mucked up
my terminal, too. Lovely stuff. (Answer in FAQ: install rxvt and a
particular font. I don't -want- rxvt. I want my gnome-terminal and its
normal settings which suit my eyes.) I have a cute screenshot of this:
I can attach it if you want.

The FAQ contains the superb combination of "Use English..." and "if your
speaking Iraqie then..." in two consecutive sentences (and is riddled
withsuch misspellings and misunderstandings of "two/too/to" ,not to
mention "your/you're", and so on that I feel justified in making this
comment, which normally I wouldn't make.

Things that would help:

* Consider a different default signoff and ircname. It makes you feel
stupid to realise everyone has been watching you and many have been
laughing, and some of the signoffs are the sort that would embarrass
many.
* Spell-check it. Including those signoffs and kick excuses.
* Fix the mess it makes of my gnome-terminal.
* Dump the package altogether.

I favour the latter.
Comment 1 Preston Brown 2001-06-05 17:04:38 EDT
you are so right.  This software is leaving.
Comment 2 Tim Powers 2001-06-05 17:13:55 EDT
Whoa. Point made :)

Consider it dead (we won't ship it anymore). Use epic instead. I don't *think*
that one is anything like bx as far as the profanity goes, and it'll probably
work better on gnome-term too :)

Thanks for the heads up Telsa. Reslolving as rawhide, because there is no
"package is dead" option :P

Tim
Comment 3 Need Real Name 2001-07-17 09:58:56 EDT
What a way to wake up. T he bugtraq thing generated a nice explosion of emails 
for me, and I really appreciate them. Notice the sarcasm? Im glad people have 
the time to devote to the meaningful things in reality, such as whining about 
the grammar of the documentation of an IRC chat client.

From my point of view, nothing that was mentioned here cannot be corrected on 
the user side, or the side of the developers. Some are simple declarations of 
variables that are mentioned in the very documentation your associates have 
complained about. 

For example, and I wont go into detail, mainly due toe the fact that you may 
learn something about UNIX and variables if you go figure this out yourself. 
And being that you discarded a package rather then set some variables, Im not 
very sure you know how. So Ill give you a few tips. The location of the 
bitchx.* files is configurable based on a simple variable.

Other items complained about were; 

1. Bitchx.quit being obnoxious
Its ASCII, redhat can freely change it, they dont have to use our example 
config files

2. The commands /fuck and /shit
They can be altered in the source if you really want to get down to it, but 89% 
of irc clients use the terminology 'shitlist' so, changing that would be simply 
silly, as for /fuck, it is an accurate description of what the command does. I 
mean, I could change it 
to /idontlikeyouandimsorryihavetodothisbutcouldyoupleaseleavemealonethankyougood
bye
But well, then you're just being silly, most people never even use the /fuck 
command, and it can be removed if you really feel the need, from the source, 
and from the simple to edit help file.

3. Bitching about the gnome terminal display
Just set your damn terminal up right, I use the gnome, and it works fine for 
me, but then, I'm not lazy enough to click, and when it doesnt work as I want 
it to, blame the programmers who wrote it, instead of myself. Its a user side 
configuration

4. The FAQ, has 'bad English' so? Its written by the man whom I personally 
dislike/distrust, and threes no love lost between us, but he is an American. 
I'm sorry if his use of poor grammar and spelling offends some people ever-
sensitive eyes. 

5. Mocking the user?
We mock ourselves, not the user, those who take themselves too seriously, as 
the author of this lovely bugtraq article seem to, are the point of are satire. 
If you cant laugh at yourself, then sir, you shouldnt be on irc.

6. Offensive Language in your distro. 
Have you even looked at the Linux kernel? Enough said. 



And last, but not least. If you cannont handle some jocular profanity, then why 
would you want to run a program called "BitchX" in the first place. Its sort of 
ironic to complain about profanity inside of a program whose name is in itself, 
a profanity. I doubt this man would be able to handle 20 minutes in most IRC 
chat rooms, people would be 'So gosh darn rude, like, for sure!'

</flame>

Robert F. Durdle
Documentation/Quality Control
The BitchX Project
Comment 4 master 2001-07-17 20:18:16 EDT
dumbass, go back to windows
Comment 5 Michael Lombardi 2001-07-17 20:26:46 EDT
First of all, I was reading the article posted, and yet have I seen something 
put so ignorant. For one, BitchX is a client, not a Rated-PG movie. Second of 
all, and who are you people to judge? Redhat is by far the worst OS I have ever 
seen, so instead of "shipping" BitchX out with the package, don't bother 
shipping Redhat at all. I'd also like to put so eloquently, The user has the 
control to change *ANY* setting, however I take is you don't understand how.So, 
I suggest getting your facts straight before you post horrible subjects due to 
a clients 'Language' and what we call 'Un-noticable' bugs. The way I see it,
the Redhat Team is too ignorant to read BitchX.doc
   
   
-- 
Michael Lombardi  
myke@neglected.net
-bitchx project 


P.S. Kindly have timp@redhat.com spellcheck this for me, I left my websters 
dictionary at home.

Note You need to log in before you can comment on or make changes to this bug.