Bug 436108 - installing kernel fails with nash fault, kernel not configured properly
installing kernel fails with nash fault, kernel not configured properly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 08:49 EST by Michal Nowak
Modified: 2013-03-07 21:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-22 07:17:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2008-03-05 08:49:14 EST
Description of problem:

When installing 

kernel             i686       2.6.24.3-12.fc8  updates-testing    17 M

I end up with 

Installing: kernel                       ##################### [ 31/188] 
nash received SIGSEGV!  Backtrace (11):
/sbin/nash[0x805314a]
[0x12c440]
/lib/libglib-2.0.so.0[0x4c22bf1]
/usr/lib/libbdevid.so.6.0.19(bdevid_module_unload_all+0x31)[0x135e37]
/usr/lib/libbdevid.so.6.0.19(bdevid_destroy+0x2d)[0x13557c]
/usr/lib/libnash.so.6.0.19[0x197174]
/usr/lib/libnash.so.6.0.19(nash_vitals_destroy_probes+0x3f)[0x1977ec]
/usr/lib/libnash.so.6.0.19(_nashFreeContext+0x1c)[0x187fc6]
/sbin/nash[0x80536e4]
/lib/libc.so.6(__libc_start_main+0xe0)[0xbf0390]
/sbin/nash[0x804ae61]

the kernel is itself installed but the grub lines are not configured.

This is the first kernel I ran into problems.

Maybe it's nash fault but there's no BZ component for this.

Version-Release number of selected component (if applicable):

kernel-2.6.24.3-12.fc8
nash-6.0.19-4.fc8

How reproducible:
always

Steps to Reproduce:
1. install recent fedora-testing kernel mentiond version
2. see failure
3. process won't finish
Comment 1 Michal Nowak 2008-03-05 15:31:06 EST
Forgot to mention that initrd file was not created.
Comment 2 John H 2008-03-07 19:47:58 EST
I'm getting same thing with the one that is in updates, not updates-testing.
Comment 3 John H 2008-03-07 19:48:35 EST
The error is HAPPENING ON the initrd file creation.

Run mkinitrd and you'll see the exact error.
Comment 4 Chuck Ebbert 2008-03-07 20:35:43 EST
This is caused by installing an incompatible glib2 package, it seems...
Comment 5 John H 2008-03-07 20:37:35 EST
Downgrading from 2.15 glib2 to 2.14 fixed it for me.  Unfortunately, new
evolution requires 2.15
Comment 6 Michal Nowak 2008-03-16 05:55:55 EDT
Any progress here?
Comment 7 Michal Nowak 2008-04-02 10:53:32 EDT
Yeah... had the FC9 glib2 package (because of new Evince depending on gio), now
having glib2-2.14.6-1.fc8. Which runs OK (even Evolution "from" comment #5).
Comment 8 Michal Nowak 2008-07-22 07:17:18 EDT
per Comment #7

Note You need to log in before you can comment on or make changes to this bug.