Bug 436111 - kernel: PCI-DMA: Out of SW-IOMMU space for 16384 bytes at device 0000:00:1f.2
kernel: PCI-DMA: Out of SW-IOMMU space for 16384 bytes at device 0000:00:1f.2
Status: CLOSED DUPLICATE of bug 433554
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jeff Garzik
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 09:12 EST by Michal Nowak
Modified: 2013-07-02 22:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 09:48:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2008-03-05 09:12:23 EST
Description of problem:

I am facing this not so nice message in dmesg

Mar  5 15:00:54 dhcp-lab-198 kernel: PCI-DMA: Out of SW-IOMMU space for 16384
bytes at device 0000:00:1f.2
Mar  5 15:00:54 dhcp-lab-198 kernel: ata1.00: exception Emask 0x0 SAct 0x800000
SErr 0x0 action 0x0
Mar  5 15:00:54 dhcp-lab-198 kernel: ata1.00: cmd
61/00:b8:19:d7:50/04:00:11:00:00/40 tag 23 ncq 524288 out
Mar  5 15:00:54 dhcp-lab-198 kernel:          res
40/00:b4:e9:c0:50/00:00:11:00:00/40 Emask 0x40 (internal error)
Mar  5 15:00:54 dhcp-lab-198 kernel: ata1.00: status: { DRDY }
Mar  5 15:00:54 dhcp-lab-198 kernel: ata1.00: status: { DRDY }
Mar  5 15:00:54 dhcp-lab-198 kernel: ata1.00: configured for UDMA/133
Mar  5 15:00:54 dhcp-lab-198 kernel: ata1: EH complete
Mar  5 15:00:54 dhcp-lab-198 kernel: SCSI device sda: 488281250 512-byte hdwr
sectors (250000 MB)
Mar  5 15:00:54 dhcp-lab-198 kernel: sda: Write Protect is off
Mar  5 15:00:54 dhcp-lab-198 kernel: SCSI device sda: drive cache: write back

while running `yum upgrade` and might be others operations.

I am not sure whether is it problem or not but might looks kinda scary to someone.

Version-Release number of selected component (if applicable):

Linux dhcp-lab-198.englab.brq.redhat.com 2.6.18-83.el5xen #1 SMP Thu Feb 21
12:44:14 EST 2008 i686 i686 i386 GNU/Linux

How reproducible:
when yum is running

Steps to Reproduce:
1. yum upgrade
2. see dmesg
  
Actual results:

weird msg in dmesg, might be some a bug in recent kernel, because it appeared
first in -83 kernel version.

Expected results:
not sure... no msg when it's normal operation, bug fixed when it's kernel side issue

Additional info:

the HDD is

SATA_WDC_WD2500JS_75_WD_WCANKH571533

(^ HAL info)

machine is 

DELL Precision 490
Comment 1 Don Zickus 2008-03-10 09:48:05 EDT

*** This bug has been marked as a duplicate of 433554 ***

Note You need to log in before you can comment on or make changes to this bug.