Bug 436176 - telinit doesn't seem to be able to connect
telinit doesn't seem to be able to connect
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: upstart (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Casey Dahlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 14:19 EST by Kevin Fenzi
Modified: 2014-06-18 04:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 13:18:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -f of telinit 6 (4.33 KB, text/plain)
2008-03-05 23:06 EST, Kevin Fenzi
no flags Details

  None (edit)
Description Kevin Fenzi 2008-03-05 14:19:06 EST
/sbin/telinit 6

gives: 

telinit: Unable to send message: Connection refused

Doesn't seem to be a selinux related issue.
Comment 1 Bill Nottingham 2008-03-05 22:45:00 EST
Is this after installing upstart but before rebooting? What do you get if you
strace it?
Comment 2 Kevin Fenzi 2008-03-05 23:05:12 EST
Fresh rawhide install from today. 
Reboot before or after, doesn't matter... does the same... 

I'll attach a strace output. 
Comment 3 Kevin Fenzi 2008-03-05 23:06:19 EST
Created attachment 296993 [details]
strace -f of telinit 6
Comment 4 Bill Nottingham 2008-03-05 23:51:09 EST
I'm assuming upstart's init still seems to be running OK?
Comment 5 Kevin Fenzi 2008-03-06 02:12:54 EST
Yeah, seems to be: 

[root@rawhide-20080305x8664 ~]# ps auxww | grep init
root         1  0.0  0.0  10440   740 ?        Ss   Mar05   0:01 init [5]      
                                                        

Comment 6 Bill Nottingham 2008-03-06 12:53:14 EST
Do things like 'initctl events' and similar work?
Comment 7 Kevin Fenzi 2008-03-06 13:32:24 EST
Nope.

[root@rawhide-20080305x8664 ~]# initctl events
initctl: Unable to send message: Connection refused

Happy to provide ssh access to the vm if you want to poke around. 
Comment 8 Joe Nall 2008-03-11 12:59:13 EDT
I see this in selinux mls policy.

Mar 11 11:45:49 rawhide kernel: type=1400 audit(1205253937.770:3): avc:  denied  { sendto } for  
pid=1 comm="init" path=002F636F6D2F7562756E74752F757073746172742F31343132 
scontext=system_u:system_r:init_t:s0-s15:c0.c1023 tcontext=system_u:system_r:initrc_t:s0-
s15:c0.c1023 tclass=unix_dgram_socket

If you grep for initrc_t in /var/log/messages or /var/log/audit/audit.log do you see similar avcs (without 
the -s15: c0.c1023)?
Comment 9 Joe Nall 2008-03-11 13:02:21 EDT
Duplicate of 436783?
Comment 10 Kevin Fenzi 2008-03-11 13:09:51 EDT
On further poking, my issue seemed to be that sysvinit was installed as well as
upstart, so /sbin/init was sysvinit and telinet was from upstart. ;) 

I couldn't duplicate it after newer rawhides removed everything from sysvinit. 

I also did try with 'setenforce 0' and didn't see any selinux issues. 

i think this can be CLOSED->rawhide for now. 

Note You need to log in before you can comment on or make changes to this bug.