Bug 436179 - Fails to start HVM DomU
Fails to start HVM DomU
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 14:28 EST by Robert Locke
Modified: 2008-11-26 10:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 10:41:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager log (109.36 KB, text/plain)
2008-03-05 14:28 EST, Robert Locke
no flags Details
xend log (1000.10 KB, text/plain)
2008-03-05 14:31 EST, Robert Locke
no flags Details
yum log (2.48 KB, text/plain)
2008-03-05 14:36 EST, Robert Locke
no flags Details
virsh dumpxml (1006 bytes, text/xml)
2008-03-06 16:56 EST, Robert Locke
no flags Details
xm list --long (1.83 KB, text/plain)
2008-03-06 16:57 EST, Robert Locke
no flags Details

  None (edit)
Description Robert Locke 2008-03-05 14:28:53 EST
Description of problem:

DomU previously worked, but now fails to start with following error:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 472, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 379, in startup
    self.vm.create()
  File "/usr/lib/python2.5/site-packages/libvirt.py", line 240, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: virDomainCreate() failed POST operation failed: (xend.err 'int
argument required')

Version-Release number of selected component (if applicable):
virt-manager-0.5.3-1.fc8
xen-libs-3.1.2-2.fc8
xen-3.1.2-2.fc8
kernel-xen-2.6.21.7-2.fc8
libvirt-python-0.4.0-4.fc8
libvirt-0.4.0-4.fc8

How reproducible:
Every time

Steps to Reproduce:
1. Boot system
2. Launch virt-manager, double-click localhost, double-click DomU
3. Click Run
  
Actual results:
Error message as displayed above

Expected results:
DomU should start and display running console

Additional info:
Comment 1 Robert Locke 2008-03-05 14:28:53 EST
Created attachment 296915 [details]
virt-manager log
Comment 2 Robert Locke 2008-03-05 14:31:00 EST
Created attachment 296916 [details]
xend log
Comment 3 Robert Locke 2008-03-05 14:36:44 EST
Created attachment 296917 [details]
yum log

List of packages that have changed since the last successful running of this
DomU.  Appears to perhaps be related to latest xen and xen-libs update?
Comment 4 Cole Robinson 2008-03-06 15:38:16 EST
Can you do a 'virsh dumpxml <guestname>' and 'xm list --long <guest name>' from
the console and post the results here? Thanks.
Comment 5 Robert Locke 2008-03-06 16:56:15 EST
Well, I got this to eventually work.  I had never had an virsh xml file, nor an
xm  config file, I had only ever used virt-manager to create/install initially
and subsequently start the WinXP HVM.  I did as you seem to be sending me, the
'virsh dumpxml WinXP > WinXP.xml' , and subsequently I did a 'virsh create
WinXP.xml' and got it to start.  Of course, my time was off (defaulted
apparently to utc) and my mouse gave me fits of not 'fully' following me.  I am,
unfortunately, attaching the now fixed up xml file of the "running" DomU (all I
changed was the clock and mouse lines), but got it working with virsh create then.
Comment 6 Robert Locke 2008-03-06 16:56:45 EST
Created attachment 297110 [details]
virsh dumpxml
Comment 7 Robert Locke 2008-03-06 16:57:46 EST
Created attachment 297111 [details]
xm list --long
Comment 8 Cole Robinson 2008-03-11 10:23:00 EDT
Using guests based on config files isn't actually what I meant, I just wanted to
see the output. I'm more interested in how you got that original error.

Can you still reproduce the original error? If so, can you reproduce by creating
a new guest or just by using a pre-existing one? Also if you are still having
issues, please give the version of python-virtinst as well.
Comment 9 Robert Locke 2008-03-17 20:21:07 EDT
Well, not sure how I got the original error, but it has re-appeared this evening....

virt-viewer-0.0.2-2.fc8
virt-manager-0.5.3-1.fc8
libvirt-python-0.4.0-4.fc8
libvirt-0.4.0-4.fc8
python-virtinst-0.300.2-3.fc8
Comment 10 Robert Locke 2008-03-17 21:02:21 EDT
"Fixing" is the following steps:

xm destroy WinXP
service xend restart
virsh create WinXP.xml

Then I can connect to the console through virt-manager.  It also now can be
shutdown from virt-manager and "run" again later.  Still not sure what
precipitated the initial "breakage", but the fact that it recurs is interesting
perhaps.
Comment 11 Bug Zapper 2008-11-26 05:01:49 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Cole Robinson 2008-11-26 10:41:34 EST
Hi, this bug has been sitting still for quite a while. If anyone can find a way
to reliably report the initial error, please file a bug against xen. I'm pretty
certain this isn't a virt-manager issue: virt-manager does all it's work
through libvirt or xen. So setting to CLOSED. If I got this wrong, please
reopen.

Note You need to log in before you can comment on or make changes to this bug.