Bug 43619 - Can't configure HP laserjet 6L with printconf
Can't configure HP laserjet 6L with printconf
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-05 18:22 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-25 08:37:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-06-05 18:22:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19 i586)

Description of problem:
I attempted to setup an HP laserjet 6L using the printconf utililty (RH
7.1).  After finishing the configuration I tried to print the ASCII and
postscript test pages.  The ASCII test page printed OK, but trying to print
the postscript test page resulted in pages and pages of garbage:  the first
page had 2 lines on it, begining ") HP-PCL XL;1;1" followed by a line of
seemingly random ASCII characters, the following pages had 2-3 lines of
garbage.

After exiting from printconf, I tried printing my own "test page" from
Abiword and from StarOffice.  I got more of the same garbage.

I had been using this printer previously under RH 6.2, setup with the
printtool utility, so I did an "rpm -e printconf" and installed printtool
from RH 7.0.  I was able to set up the printer correctly using
printtool-3.54-1, and the printer is now working fine.

How reproducible:
Always

Steps to Reproduce:
1. install printconf
2. run printconf -- setup for HP lj 6L
3. print postscript test page
	

Actual Results:  Printer spewed out pages and pages of garbage.

Expected Results:  Printer should print the postscript test page correctly.

Additional info:
Comment 1 Paul Johnson 2001-06-06 15:09:36 EDT
I have same problem, trying to print to an HP6L through a SMB networking. It
worked fine in RH6.2 and 7.0.

After days of fussing with it, I removed printconf and printconf-gui and got the
Redhat 7.0 disk and installed rhs-printfilters and printtool.  The printer works
again after reinstalling the printers.
Comment 2 David Spinella 2001-06-18 20:13:59 EDT
I had the identical problem - my Laserjet 6L worked with Redhat 6.2 but not with
7.1.  I contacted Redhat technical support and was instructed by Matt Drew to
remove my printconf and printconf-gui and to install the 7.0 rhs-printfilters
and printtool which I found at the Redhat FTP site.  Now I can print StarOffice
and KMail documents without a problem.

David Spinella
Comment 3 Gregg Burton 2001-06-30 16:00:45 EDT
Same problem.  I get garbage with both ASCII and PS output.  I just discovered
the problem yesterday and so I don't have much more information on the issue.  I
don't have any new information to add, other than to verify the existence of the
bug.  I would like to add however, that as to the severity of this problem, this
is a "total failure" bug that relates to the driver for one of the most widely
used consumer laser printers on the market.... (ie not good).
Comment 4 Jason Grant 2001-07-14 03:57:59 EDT
Same problem for me too.

Can we escalate this one?  I've seen the same fault reported elsewhere for other
HP series printers too (e.g. forums on linuxprinting.org, and newsgroup
linuxprinting.hp.general).

Thanks,

Jason.
Comment 5 Nils Philippsen 2001-08-03 11:54:00 EDT
The same here (just that the printer in question is a 5L, not a 6L). It's most
likely that this is a bug in foomatic and/or ghostscript though.

When Selecting the LJ4 driver and printing the A4 test page, it gets printed but
is shifted upwards about 2 centimeters. On the following page (but only if I
issue another print job), some random HP PJL stuff appears.

Crutcher, this bug is still there in Roswell (and rel-eng past it), is this
fixable?
Comment 6 zwhitley 2001-08-07 14:20:39 EDT
I've had the same problem with a LaserJet 5L. The problem was fixed by changing
the printer driver from ljet5grey to ljet4 (that takes care of printing garbage)
but I can't set the driver option "Rerender postscript" and printing from ggv
prints raw postscript.
Comment 7 Rabbe Fogelholm 2001-08-12 10:03:02 EDT
I too had the same problem that many people reported above (my printer is a
HP LaserJet 5L).To assist all who want to fix things, my workaround was as follows:

1. be root

2. cd /etc/rc.d/init.d; ./lpd stop

3. rpm --erase printconf printconf-gui

4. download printtool and rhs-printfilters from some Red Hat mirror
(the path ends in .../redhat/linux/7.0/en/os/i386/RedHat/RPMS)

5. rpm -Uvh printtool-* rhs-printfilter-*

6. edit /etc/printcap, tear out entry for LaserJet 5L created with printconf
(hmm, probably this could have been done by printconf too)

7. run printtool from a shell window and configure the LaserJet 5L again

8. do lpd->restart

9. print test pages, should work now

10. optionally, use your desktop manager's Menu Editor or such and define a
menu entry for running printtool with root privileges
Comment 8 Tim Waugh 2002-01-18 16:41:14 EST
Do the packages at <ftp://people.redhat.com/twaugh/errata-candidate/> help?
Comment 9 Need Real Name 2002-01-19 19:53:53 EST
I've just tried the new RPMs provided and can confirm that my HP LaserJet 6L
works perfectly with the "ljet4" driver!

Just to confirm, the files I've used are:

printconf-0.3.61-1.1.i386.rpm
printconf-gui-0.3.61-1.1.i386.rpm
foomatic-1.1-0.20011218.1.4.i386.rpm

Many, many thanks Mr Waugh!
Comment 10 Nils Philippsen 2002-01-20 11:13:11 EST
Tim,

I can confirm that on 5L (with the ljet4 driver), at least for now (I've become a
little paranoid here). The Omni driver doesn't work at all so it should probably
be disabled for 5L/6L.
Comment 11 Paul Johnson 2002-01-20 16:29:17 EST
Trying to install this foomatic package hangs rpm. It counts up to 100% but
never finshes, there is no error. After killing it at that point, the package
verifies correctly as installed. However, when I run printconf-gui, I get the
error that lpd cannot be restarted.
Comment 12 Tim Waugh 2002-01-20 17:14:20 EST
pauljohn@ukans.edu: what does it say if you run (as root)?:

rm -rf /var/cache/foomatic/pcache/* /var/cache/foomatic/compiled/*
/usr/sbin/printconf-backend --force-rebuild
Comment 13 Paul Johnson 2002-01-20 17:48:59 EST
I traced back the problem to a "hang" (??) somewhere between smb and lpd
processes. lpd couldn't restart, and smb couldn't restart, don't know why.
Anyway, after restarting linux, I removed and reinstalled your new foomatic. 
. That time it did not hang at install time. 

Then I got your email, tried your instructions here:

# rm -rf /var/cache/foomatic/pcache/* /var/cache/foomatic/compiled/* 
# /usr/sbin/printconf-backend  --force-rebuild

produced no output, so all must be well.

After restarting, I have some good and bad news.

1. I am able to print to a Novell server print queue on an HPLaserJet4m.  The
test output from printconf is centered and looks fine.

2. I also (vitally!) need to print to an smb printer on Windows NT system.
That's a HP 6L.  The printout os no good.  Across the top, I see about the
bottom quarter of the guy with the hat and then some hearts and clovers and
nonsense characters.  I am trying the LJet4 driver, which is the only one I see
under 6L.

In printconf-gui, I'm looking at various options, and if i try "rerender
postscript" then nothing comes out of the printer at all, but there  is no error
message when I try to print a page. I've experimented with other options, no help.

I notice one weird thing. If I make a change and save the changes, then when I
try to test print a page, it tells me I have unsaved changes. Should it do that?

I've opened staroffice to try to test printing. I find I'm able to print to file
in ps format. If I send the same image to the printer (I think it uses lp as
default), I can see the printer lights flash, but nothing happens until I print
several times, and then a page of nonsense comes out. Incredibly, what comes out
is a bit of the redhat test page "The boxes bordering this page" and some really
really small stuff below that.
Comment 14 Tim Waugh 2002-01-21 08:54:40 EST
Do you have the option enabled to translate linefeeds to carriage 
return/linefeed pairs?  If so, disable it.
Comment 15 Paul Johnson 2002-01-21 16:18:11 EST
OK, I'm almost all fixed now!  after turning off the button "translate \n->\r\n"
then I can test print the redhat page. Great.

I noticed that the output on the 6L is not centered correctly.  I at first
suspected the paper feed was bad and experimented, then I removed printconf-gui
and reinstalled printtool and the page became correctly centered again. The
output is slightly "tilted" on the page, however.

Then I noticed in the comments that come along with the Ljet4 driver indication
that another tester reported the off center and tilted output from that driver,
and all I can say is "me too"!  The entry from the driver maintainer says I need
to learn to use ghostscript to manage margin settings (how?) and he just says he
does not believe there could be a tilt in the output. Too bad. The output from
the HP4M is not tilted. 
Comment 16 Need Real Name 2002-01-21 19:03:29 EST
Are the packages at ftp://people.redhat.com/twaugh/errata-candidate/ indended
for a RH7.2 system (the bug was originally filed against 7.1)?

After several hours of downloading/installing/rebuilding many RH7.2 packages, I
managed to satisfy all the dependencies for my RH7.1 machine.  However, when I
try to run printconf-gui I get this:

[root@hippo errata-candidate]# printconf-gui
sh: /var/cache/foomatic/compiled/overview.xml: No such file or directory
cat: /var/cache/foomatic/compiled/overview.xml: No such file or directory
Traceback (innermost last):
  File "/usr/sbin/printconf-gui", line 8, in ?
    printconf_gui.startup_and_find_cmd()
  File "/usr/share/printconf/util/printconf_gui.py", line 2044, in
startup_and_find_cmd
    main.cmd_handlers[cmd]()
  File "/usr/share/printconf/util/printconf_gui.py", line 1999, in gui_main_run
    foomatic_init_overview()
  File "/usr/share/printconf/util/printconf_conf.py", line 1279, in
foomatic_init_overview
    root = parser.parse(foo.fromchild)
  File "/usr/lib/python1.5/site-packages/xml/utils/qp_xml.py", line 134, in
parse
    p.Parse('', 1)
xml.parsers.expat.error: no element found: line 1, column 0



There is nothing in /var/cache/foomatic/:
[root@hippo foomatic]# ls /var/cache/foomatic/
[root@hippo foomatic]# 

Comment 17 Tim Waugh 2002-01-23 09:05:11 EST
grover@marshall.edu: Oh, right, no they won't work on 7.1.  I'll look at
putting some 7.1 packages together for the errata.
Comment 18 Tim Waugh 2002-01-23 12:19:45 EST
Hmm, it'll probably be a separate advisory actually.
Comment 19 Tim Waugh 2002-02-22 07:39:15 EST
Since I have had lots of positive feedback concerning the latest 7.2 printing
errata packages, and since printing changed quite a lot between 7.1 and 7.2, I
am closing this as 'resolved in the current release'. (Sorry!)

Note You need to log in before you can comment on or make changes to this bug.