Bug 436214 - Allow > 255 keycodes
Allow > 255 keycodes
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
http://bugs.freedesktop.org/show_bug....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 17:11 EST by Nicolas Mailhot
Modified: 2008-07-18 01:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-18 01:26:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 7734 None None None Never
FreeDesktop.org 11227 None None None Never

  None (edit)
Description Nicolas Mailhot 2008-03-05 17:11:38 EST
Description of problem:

The zoom+, zoom- and spell keys of the Microsoft Natural Ergonomic Keyboard
4000 are not working in Xorg.

The kernel developers affirm their part work and blame xorg

(note that this is not an evdev indictment, without evdev there would not be 3
but 33 dud keys on this very popular keyboard. This is a "mop up remaining
problems" ticket)

Version-Release number of selected component (if applicable):
xorg-x11-server-common-1.4.99.900-0.28.20080304.fc9.x86_64
kernel-2.6.25-0.90.rc3.git5.fc9.x86_64

Additional info:
http://bugzilla.kernel.org/show_bug.cgi?id=7734
https://bugs.freedesktop.org/show_bug.cgi?id=14843
Comment 1 Matěj Cepl 2008-03-05 17:59:03 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Nicolas Mailhot 2008-03-06 05:49:52 EST
Seems the problem is known upstream and actively discussed in another issue,
changing issue title and upstream bug reference

http://bugs.freedesktop.org/show_bug.cgi?id=11227
Comment 3 Matthias Clasen 2008-03-17 08:38:16 EDT
This is certainly not something that can be done for F9
Comment 4 Bug Zapper 2008-05-14 01:48:11 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Peter Hutterer 2008-07-18 01:26:44 EDT
This needs to be resolved upstream first.

Note You need to log in before you can comment on or make changes to this bug.