Bug 436219 - Printing side by side pages with an odd # paged document drops last page
Printing side by side pages with an odd # paged document drops last page
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 17:48 EST by Edward Rudd
Modified: 2008-09-10 11:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 07:08:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Rudd 2008-03-05 17:48:48 EST
Description of problem:
Printing side by side pages with an odd # paged document drops last page

Version-Release number of selected component (if applicable):
2.3.0-6.11.fc8@x86_64

How reproducible:
every time

Steps to Reproduce:
1. Start with a document that is 13 pages long.
2. Open the print dialog (File/Print  or Ctrl-P)
3. Choose the "Page Setup" tab
4. Change the Pages per side to "2"
5. Leave "Two-Sided" as "One Sided"
6. Choose the "Properties" Tab
7. Change the "Orientation" to "Landscape"
8. Click "Print"
  
Actual results:
I get pages 1 through 12 printed side by side on 6 pieces of Paper. I do NOT get
page 13 at all.

Expected results:
Page 13 to be on the left side of a page by itself.

Additional info:
If I add a 14th blank page, it prints fine.
Comment 1 Caolan McNamara 2008-03-06 03:48:49 EST
Does it make any difference to print to file as postscript, and to open that
file in evince and then print from evince with the same options as above ?
Comment 2 Edward Rudd 2008-03-06 09:25:21 EST
If I print to file I lose the ability to set the Pages per side option and it 
just creates a PDF/PS of 1 page per page. 
Comment 3 Caolan McNamara 2008-03-06 09:32:48 EST
open that .ps file that has one page per page in evince and then that print from
evince with the 2 pages per sheet option and see does that work or also fail
Comment 4 Edward Rudd 2008-03-10 16:14:54 EDT
This time a 3 page document..

From the PDF output from OpenOffice printed from Evince using 2 pages per sheet,
it prints fine.

However printing the same document from within OpenOffice, 2 pages/sheet.  it
only prints the first page of 2 pages. it fails to print the 3rd "original page".

Yup, does look like some bug in OpenOffice/ the openoffice gnome print integration.
Comment 5 Caolan McNamara 2008-03-11 04:40:29 EDT
Does it make any difference to print to file as *postscript*, and to open that
file in evince and then print from evince with the same options as above ?
Comment 6 Jia Dong 2008-09-10 06:57:34 EDT
The different version of OpenOffice I tested:
 2.3.0-6.6.fc8@x86_64 
 2.4.0-12.8.fc9@x86_64
 2.3.0-6.16.fc8@x86_64
 
 The results are as expected correctly and the
 described bug didn't reappear.


 My actions is as follows:

 1. Created a document that is 13 pages long.
 2. Opened the print dialog (File->Print) 
 3. Selected an available printer in  "General" tab
 4. Selected "1" of "Copies" options in "General" tab
 5. Selected "All" of "Print Pages" options,then left others originally in "General" tab
 6. Clicked the "Page Setup" tab and changed the "Pages per side"  to "2"
 7. Set "Two-Sided" with "One Sided" in "Page Setup" tab, then left others originally 
 8. Chose the "Properties" Tab and changed the "Orientation" to
 "Landscape"
 9. Clicked "Print"

 Result:
   Printer printed 7 pages copy as expected.
Comment 7 Caolan McNamara 2008-09-10 07:08:38 EDT
ok, so whatever the problem is we can't get it to happen for us :-( If there is some alternative way of achieving the problem feel free to reopen this bug

Note You need to log in before you can comment on or make changes to this bug.