Bug 436221 - [RHEL4 U7] kernel s390 problem reading core file, kernel maps permissions
[RHEL4 U7] kernel s390 problem reading core file, kernel maps permissions
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.7
s390 Linux
low Severity high
: rc
: ---
Assigned To: Jan Glauber
Martin Jenner
http://rhts.redhat.com/cgi-bin/rhts/t...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 18:00 EST by Jeff Burke
Modified: 2008-07-02 11:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-02 08:56:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vsyscall test (5.09 KB, application/octet-stream)
2008-03-26 08:40 EDT, Jeff Burke
no flags Details

  None (edit)
Description Jeff Burke 2008-03-05 18:00:58 EST
Description of problem:
 We have been tracking an issue that only showed up very intermittently. Until
the latest kernel run on 2.6.9-68.17.EL. The vsyscall test failed on all s390
jobs with the same thing.

 Note sure if the issue is with gcore, gdb or kernel. This is very similar to
https://bugzilla.redhat.com/show_bug.cgi?id=231327

Version-Release number of selected component (if applicable):
 2.6.9-68.17.EL

How reproducible:
 It was intermittent. But was consistent with 2.6.9-68.17.EL on RHEL4-U6 base
distro.

Steps to Reproduce:
1. Install RHEL4-U6 install 2.6.9-68.17.EL kernel
2. Run the RHTS test rh-tests-kernel-syscalls-vsyscall-1.2-5
  
Actual results:

***** Starting the runtest.sh script *****
***** Current Running Kernel Package = kernel-2.6.9-68.17.EL.s390 *****
***** Current Running Distro = Red Hat Enterprise Linux AS release 4 (Nahant
Update 6) *****
***** Note: It is by design that this will segfault and create a core file *****
Using host libthread_db library "/lib/tls/libthread_db.so.1".
Core was generated by `./small'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /lib/tls/libc.so.6...done.
Loaded symbols for /lib/tls/libc.so.6
Reading symbols from /lib/ld.so.1...done.
Loaded symbols for /lib/ld.so.1
#0  0x77ec586a in kill () from /lib/tls/libc.so.6

Thread 1 (process 21257):
#0  0x77ec586a in kill () from /lib/tls/libc.so.6
#1  0x00400678 in handle_alrm (signo=14) at small.c:17
#2  <signal handler called>
#3  0x77f29b42 in __pause_nocancel () from /lib/tls/libc.so.6
#4  0x00400744 in main (argc=1, argv=0x7ffff994) at small.c:32
RESULT of kernel core generator: Passed
Using host libthread_db library "/lib/tls/libthread_db.so.1".
Attaching to program: /mnt/tests/kernel/syscalls/vsyscall/small, process 21263
Reading symbols from /lib/tls/libc.so.6...done.
Loaded symbols for /lib/tls/libc.so.6
Reading symbols from /lib/ld.so.1...done.
Loaded symbols for /lib/ld.so.1
0x77f29b40 in ?? ()
Saved corefile core.gcore
Using host libthread_db library "/lib/tls/libthread_db.so.1".
Core was generated by `/mnt/tests/kernel/syscalls/vsyscall/small'.
Reading symbols from /lib/tls/libc.so.6...done.
Loaded symbols for /lib/tls/libc.so.6
Reading symbols from /lib/ld.so.1...done.
Loaded symbols for /lib/ld.so.1
#0  0x77f29b40 in ?? ()

Thread 1 (process 21263):
#0  0x77f29b40 in ?? ()
RESULT of kernel maps permissions: Failed
RESULT: some tests Failed
***** End of runtest.sh *****

Expected results:
  Should pass

Additional info:
Comment 1 Jan Kratochvil 2008-03-07 14:53:27 EST
A note it is not reproducible on its own, it was probably affected by one of the
preceding tests run there.

It would be nice to get an interactive login to the machine reproducing the problem.

0x43d6fb40 <__pause_nocancel+0>:        svc     29
0x43d6fb42 <__pause_nocancel+2>:        lhi     %r4,-4095
Comment 2 Jan Glauber 2008-03-26 07:09:47 EDT
Not entirely sure what vsyscall is, but quite sure that we don't have
that on s390. Can you attach the testcase so I can have a look at it?
thanks, Jan
Comment 3 Jeff Burke 2008-03-26 08:40:25 EDT
Created attachment 299140 [details]
vsyscall test

Here is the testcase mentioned. Please note that in order to run it "as is" you
will need the RHTS developer rpms installed.
http://intranet.corp.redhat.com/ic/intranet/RHTSMainPage.html#devel
Or you will need to comment out the following lines:
 Makefile remove the include "/usr/share/rhts/lib/rhts-make.include"
 runtest.sh remove the ". /usr/bin/rhts_environment.sh"
Comment 4 Peter Martuccelli 2008-03-26 09:39:00 EDT
Jan will review the vsyscall test and determine if it is a valid issue or not. 
I am not looking at resolving this in R4.7 as an exception, moving it to R4.8.
Comment 5 Jan Glauber 2008-07-01 09:09:07 EDT
I cannot reproduce this issue on my RHEL4 guest (s390x and kernel 2.6.9-71.EL)
Did you see this problem only on s390 or also on s390x?
Comment 6 Jeff Burke 2008-07-01 09:17:51 EDT
Jan,
   I want back to look at the logs. FYI the link is in the URL section of the
BZ. It was on the s390 arch. The base distro was REHL4.6 and the U7 kernel was
tested on top of that.

Jeff
Comment 7 Jan Kratochvil 2008-07-01 14:25:20 EDT
Jeff,
as I wrote in the Comment #1 it is unreproducible for me.

While I agree the RHTS log shows something broken I am unable to fix it just
from the log file, i do not know what happened there.

As in the URL there is missing the RHTS [Clone] button for Job 17449 I tried to
reproduce it by a system reservation (Job 24535, z202.z900.redhat.com), upgraded
the kernel to kernel-2.6.9-67.0.9.EL.s390, all the packages listed there except
I used -16 as on
  http://rhts.redhat.com/rpms/development/noarch/noarch/
there is missing
  rh-tests-kernel-drivers-3rd-party-1.9-15.noarch.rpm
and after running all the tests by
  make -C /mnt/tests/$test run
it PASSed:
***** Starting the runtest.sh script *****
***** Current Running Kernel Package = kernel-2.6.9-67.0.9.EL.s390 *****
***** Current Running Distro = Red Hat Enterprise Linux AS release 4 (Nahant
Update 6) *****
***** Note: It is by design that this will segfault and create a core file *****
./runtest.sh: line 25: 11555 Segmentation fault      (core dumped) ./small
./runtest.sh: line 34: 11561 Killed                  ./small wait
***** End of runtest.sh *****
/kernel/syscalls/vsyscall result: PASS
   metric: 0
   Log: /tmp/tmp.Q11532
make: Leaving directory `/mnt/tests/kernel/syscalls/vsyscall'

So please provide a machine with the problem reproduced with a login prompt.
Comment 8 Jeff Burke 2008-07-02 08:47:08 EDT
"So please provide a machine with the problem reproduced with a login prompt."
   If I could I would. But like you I am unable to reproduce the issue.

See here:
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=24543&type=Single

If you would like please close the BZ as NOTABUG and in the future if we see the
issue again we can reopen the BZ.
Comment 9 Jan Glauber 2008-07-02 11:29:18 EDT
I cannot reproduce this on a RHEL4 Kernel 2.6.9-74.EL Snapshot4.
Closing the BZ until the issue is reproducible.

Note You need to log in before you can comment on or make changes to this bug.