Bug 436266 - can no more print from clients to rawhide
can no more print from clients to rawhide
Status: CLOSED DUPLICATE of bug 442345
Product: Fedora
Classification: Fedora
Component: system-config-firewall (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-06 04:05 EST by Steve
Modified: 2008-07-22 09:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-22 09:10:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve 2008-03-06 04:05:53 EST
Description of problem:
since a few weeks, i can no more print from any client (linux, mac, windows).
the printer is shared and there are no errors in the log. i can print from the
host itselfs. selinux is disabled.
the clients can see the printer share, but cannot print. the error message on
fedora 8 is; 'there was a problem connecting to the printer'. the printer is a
'canon i865'.

Version-Release number of selected component (if applicable):
cups-1.3.6-5.fc9.i386
cups-libs-1.3.6-5.fc9.i386
cupsddk-drivers-1.2.3-4.fc9.i386
libgnomecups-0.2.3-3.fc9.i386
gutenprint-cups-5.0.2-2.fc9.i386

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
cannot print from clients anymore

Expected results:
should print

Additional info:
Comment 1 Tim Waugh 2008-03-06 04:48:08 EST
Please start the printing configuration tool (System->Administration->Printing),
and select Help->Troubleshoot from the menu bar and follow the instructions. 
What happens?  If there is debugging output, please paste it in here.
Comment 2 Steve 2008-03-06 05:35:45 EST
there is no problem on the printer host (rawhide), and the client (f8) has no
troubleshooter. what shall i do?
Comment 3 Tim Waugh 2008-03-06 05:50:54 EST
Start the troubleshooter and select a printer.  Then, when it asks you to submit
a test print job, submit one from the F-8 client and when it appears in the
little box, select the check-box to mark it as your test job.
Comment 4 Steve 2008-03-06 07:45:43 EST
this is the joke. there is no print job from another machine (f8) in this little
box from the troubleshooter..
Comment 5 Tim Waugh 2008-03-06 08:09:24 EST
Did you submit the job to the same printer as you selected?
Comment 6 Steve 2008-03-06 08:19:17 EST
yes it did.
Comment 7 Tim Waugh 2008-03-06 08:41:26 EST
On the client, what does 'locale' say?
Comment 8 Steve 2008-03-06 09:43:04 EST
$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
$
Comment 9 Tim Waugh 2008-03-06 09:46:28 EST
Collecting more information to try to find the problem:

1. What does '/usr/sbin/cupsctl -U root' say on the rawhide CUPS server?
2. What does 'lpstat -s' say on the F-8 CUPS client, and which queues are on the
rawhide server?
Comment 10 Steve 2008-03-06 10:17:18 EST
[root@StarsEnd ~]# /usr/sbin/cupsctl -U root
MaxLogSize=0
SystemGroup=sys root
DefaultAuthType=Basic
_debug_logging=1
_remote_admin=1
_remote_any=1
_remote_printers=1
_share_printers=1
_user_cancel_any=1
[root@StarsEnd ~]#

[sysop@artchaos ~]$ lpstat -s
system default destination: i865
device for i865: ipp://192.168.100.3:631/printers/i865
[sysop@artchaos ~]$ 

There are no queues on the rawhide server.
Comment 11 Tim Waugh 2008-03-06 10:28:04 EST
But 192.168.100.3 is the rawhide machine isn't it?

Please try this:

lp -h192.168.100.3 -di865 /usr/share/cups/data/testprint.ps

What happens?
Comment 12 Steve 2008-03-06 10:32:15 EST
[sysop@artchaos ~]$ lp -h192.168.100.3 -di865 /usr/share/cups/data/testprint.ps
lp: No route to host
[sysop@artchaos ~]$
Comment 13 Tim Waugh 2008-03-06 10:42:31 EST
And

traceroute 192.168.100.3

?
Comment 14 Steve 2008-03-06 10:48:24 EST
[sysop@artchaos ~]$ traceroute 192.168.100.3
traceroute to 192.168.100.3 (192.168.100.3), 30 hops max, 40 byte packets
 1  starsend (192.168.100.3)  0.223 ms !X  0.195 ms !X  0.198 ms !X
[sysop@artchaos ~]$
Comment 15 Tim Waugh 2008-03-06 11:20:59 EST
The iptables rules on the rawhide machine are preventing inbound traffic to TCP
port 631.
Comment 16 Thomas Woerner 2008-03-06 12:15:25 EST
Please use system-config-firewall and mark your intranet interface as trusted or
mark the IPP printing service as trusted.
Comment 17 Steve 2008-03-06 12:44:19 EST
Added new port 631:tcp:ipp as trustet in system-config-firewall. I can print again.
Comment 18 Tim Waugh 2008-03-06 18:08:37 EST
Re-opening.  It's quite an imposition to expect users to know how to do this.
Comment 19 Bug Zapper 2008-05-14 01:48:54 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 20 Thomas Woerner 2008-07-22 09:10:58 EDT

*** This bug has been marked as a duplicate of 442345 ***

Note You need to log in before you can comment on or make changes to this bug.