Bug 436285 - iwlist scan returns no results for rt73 usb
iwlist scan returns no results for rt73 usb
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
high Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-06 06:39 EST by Lubomir Kundrak
Modified: 2008-05-13 14:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: kernel-2.6.24.4-82.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 14:40:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg; when doing a iwlist scan (4.78 KB, text/plain)
2008-03-06 06:45 EST, Lubomir Kundrak
no flags Details
log before iwlist scan (3.85 KB, text/plain)
2008-03-06 06:50 EST, Lubomir Kundrak
no flags Details

  None (edit)
Description Lubomir Kundrak 2008-03-06 06:39:29 EST
Description of problem:

I can not scan for APs with rt73 usb wireless device. There are three APs
around, all of them are properly seen by an internal intel wireless.

Version-Release number of selected component (if applicable):

Linux gopher 2.6.24.3-18.fc8 #1 SMP Tue Mar 4 21:14:18 EST 2008 x86_64 x86_64
x86_64 GNU/Linux

How reproducible:

Reliably

Steps to Reproduce:
1. Insert the rt73 usb wifi adapter
2. ifconfig wlan0 up
3. iwlist wlan0 scan
  
Actual results:

[root@gopher Module]# iwlist wlan0 scan
wlan0     No scan results

[root@gopher Module]# 

Additional info:

Same thing happens with driver from serialmonkey.com. Attaching output that was
appended to dmesg when the driver was loaded with debug=255.
Comment 1 Lubomir Kundrak 2008-03-06 06:45:07 EST
Created attachment 297034 [details]
dmesg; when doing a iwlist scan
Comment 2 Lubomir Kundrak 2008-03-06 06:50:12 EST
Created attachment 297037 [details]
log before iwlist scan

For sake of completeness; this happens before iwlist scan after I connect the
device
Comment 3 John W. Linville 2008-03-06 09:12:46 EST
The output you have attached does not seem to come from the in-kernel drivers 
for that hardware.  Are you using the serialmonkey drivers?  Can you replicate 
the problem using the in-kernel drivers?
Comment 4 Lubomir Kundrak 2008-03-06 09:19:25 EST
Yes, I can replicate the very same problem with in-kernel driver. I just can not
replicate the debug output :)
Comment 5 Ivo van Doorn 2008-03-09 17:54:19 EDT
This should be fixed in rt2x00 2.1.4 which was released a few minutes ago.
Comment 6 Lubomir Kundrak 2008-03-10 12:02:06 EDT
Ivo: thanks for the response.

I created a patch that replaces rt2x00 directory with a git snapshot (it was one
commit after official 2.1.4) and rebuilt the kernel package 2.6.24.3-22.fc8 with
it. Nothing changed; iwlist scan still produces no results, while the other
interface detects 4 access points.

What can I do to gather more information to debug this problem.
Comment 7 Ivo van Doorn 2008-03-13 15:12:28 EDT
There is an official kernel update:
http://koji.fedoraproject.org/koji/buildinfo?buildID=42735

Could you try that one instead?
Comment 8 John W. Linville 2008-03-14 10:14:49 EDT
Many people have reported great success with that one -- please try it.

If it works for you, please note it here as well:

   https://admin.fedoraproject.org/updates/F8/pending/kernel-2.6.24.3-34.fc8
Comment 9 Lubomir Kundrak 2008-03-16 13:43:49 EDT
Same behavior with that kernel.

(148f:2573 Ralink Technology, Corp. RT2501USB Wireless Adapter)
Comment 10 John W. Linville 2008-04-07 10:04:01 EDT
There have been lots of important rt2x00 fixes over the past three weeks.  
Would you mind (again) trying a later kernel?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=44648

Does that improve the situation?
Comment 11 Lubomir Kundrak 2008-04-12 11:35:46 EDT
John: Pardon me for delaying the reply that much -- I was struggling to get some
useful debugging information, but kdump doesn't work for me (another bug for
that open).

After "ifconfig up" the rt73usb task (or some with similar name, I don't
remember precisely) consumes 100% CPU time. While system was still more-or-less
responsive I removed the hardware and it resulted in no other task being able to
get a CPU share, system seemed frozen. SysRq worked, but I was not able to get a
kdump due to a another problem with kexec/kdump.

Is there any way I can get some useful debugging information until kexec gets
fixed? Will output of some SysRq hotkey (before unplugging the hardware) be of
any use?

Thanks.
Comment 12 John W. Linville 2008-04-17 14:59:36 EDT
The problem in comment 11 should be resolved by -82.fc8 and later.  Could you 
try these kernels?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=46436

Do they resolve the issue for you?

Note You need to log in before you can comment on or make changes to this bug.