Bug 436324 - RHEL4 installer kernels don't boot on a Intel DG965RY motherboard (G965 chipset)
RHEL4 installer kernels don't boot on a Intel DG965RY motherboard (G965 chipset)
Status: CLOSED DUPLICATE of bug 250313
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: David Howells
Martin Jenner
Depends On:
  Show dependency treegraph
Reported: 2008-03-06 10:11 EST by David Howells
Modified: 2008-03-12 14:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-12 11:17:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Disable PCI IO & MEM access on a device we're probing for BAR size (1.05 KB, patch)
2008-03-11 19:38 EDT, David Howells
no flags Details | Diff

  None (edit)
Description David Howells 2008-03-06 10:11:44 EST
Description of problem:

I tried to install the x86_64 RHEL-4 U6 installer kernel on my test machine, 
which has a DG965RY chipset - this has Intel's onboard 3D graphics controller.

The boot locks solidly during the probing of the PCI hardware as far as I can 

  PCI: Using configuration type 1
  PCI: Using MMCONFIG at f0000000
  mtrr: v2.0 (20020519)
  ACPI: Subsystem revision 20040816
  ACPI: Interpreter enabled
  ACPI: Using IOAPIC for interrupt routing
  ACPI: PCI Root Bridge [PCI0] (00:00)
  PCI: Probing PCI hardware (bus 00)

At this point, the computer must be given a hard reset.

I've tried various other RHEL-4 installer kernels too, including gold, and 
both AS and Desktop, but to no avail.  All fail in the same manner.  RHEL-5 
kernels, various Fedora kernels, and all the 2.6 kernels I've built for it 
since Sept 2006 work.  Also, i386 kernels show the same malfunction.

The same kernels do, however, boot on my desktop box, which has a DP965LT of 
similar age.  This lacks the on-board graphics.

My test box has no PCI devices plugged into the expansion bus.
Comment 1 David Howells 2008-03-11 15:40:08 EDT
I put some printks into the PCI probing code, and have determined that the box 
locks up when pci_read_bases() attempts to determine the size of 
PCI_BASE_ADDRESS_2 with this line:

		reg = PCI_BASE_ADDRESS_0 + (pos << 2);
		pci_read_config_dword(dev, reg, &l);
		pci_write_config_dword(dev, reg, ~0);  <<<<<<<<<< here
		pci_read_config_dword(dev, reg, &sz);
		pci_write_config_dword(dev, reg, l);
Comment 2 David Howells 2008-03-11 15:44:07 EDT
Adding "pci=nommconf" to the command line fixes the problem.
Comment 3 David Howells 2008-03-11 19:38:00 EDT
Created attachment 297689 [details]
Disable PCI IO & MEM access on a device we're probing for BAR size

The G965 graphics hardware BARs can be probed, provided that access through the
I/O and Memory regions on that device are disabled for the duration of the
probe.	I'm told by an Intel engineer that PCI_COMMAND_{IO,MEMORY} should
always be disabled during BAR probing.
Comment 4 Prarit Bhargava 2008-03-12 11:17:25 EDT

*** This bug has been marked as a duplicate of 250313 ***

Note You need to log in before you can comment on or make changes to this bug.