Bug 436355 - Test files for ncurses-devel can't be built
Test files for ncurses-devel can't be built
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ncurses (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-06 13:19 EST by Horst H. von Brand
Modified: 2008-03-07 08:44 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 08:44:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2008-03-06 13:19:31 EST
Description of problem:
The package ncurses-devel installs a directory full of examples and tests under
/usr/share/doc/ncurses-devel-<version>/test, but those can't be built:

  $ cp -R /usr/share/doc/ncurses-devel-5.6/test/ /tmp
  $ cd /tmp/test/

./configure is not executable, running it errors out (old autoconf stuff?)

For e.g. blue, the file states to compile by:

  cc -O blue.c -lcurses -o blue

This should be (it includes local files):

  gcc -I. -O blue.c -lncurses -o blue

but that fails due to missing test.priv.h


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Horst H. von Brand 2008-03-06 13:21:05 EST
Sorry, turned an incomplete report in.

ncurses-devel-5.6-15.20080112.fc9.i386

Fixing up the source I got blue to build (I needed it for another report).
Comment 2 Miroslav Lichvar 2008-03-07 08:44:32 EST
In ncurses-5.6-16.20080301.fc9 the missing install-sh was added to the test
directory. Documentation shouldn't have executable files, but sh ./configure &&
make should work now.

Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.