Bug 436359 - [patch] Use chkconfig to configure selected MTA to start automatically
[patch] Use chkconfig to configure selected MTA to start automatically
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-switch-mail (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-06 14:09 EST by Dax Kelson
Modified: 2008-03-17 08:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 08:42:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add chkconfig use to system-switch-mail (2.80 KB, patch)
2008-03-06 14:09 EST, Dax Kelson
no flags Details | Diff

  None (edit)
Description Dax Kelson 2008-03-06 14:09:13 EST
Description of problem:
I teach Linux classes and I notice a very common stumbling block for students
that use system-switch-mail. They think (appropriately) that system-switch-mail
handles all the changes for them, and so they never run the chkconfig commands
to turn on the selected MTA and off the unselected MTAs.

I'm attaching a patch to this bug report that adds chkconfig support to
system-switch-mail so that it truly does to all the steps required to switch
between MTAs.

I have tested it and it works:

Here is the output of the test:

STARTING POINT:
[root@mentorng ~]# chkconfig --list sendmail ; chkconfig --list postfix ;
chkconfig --list exim
sendmail        0:off   1:off   2:on    3:on    4:on    5:on    6:off
postfix         0:off   1:off   2:on    3:on    4:on    5:on    6:off
exim            0:off   1:off   2:on    3:on    4:on    5:on    6:off

run system-switch-mail and choose sendmail:

sendmail        0:off   1:off   2:on    3:on    4:on    5:on    6:off
postfix         0:off   1:off   2:off   3:off   4:off   5:off   6:off
exim            0:off   1:off   2:off   3:off   4:off   5:off   6:off

run system-switch-mail and choose postfix:

sendmail        0:off   1:off   2:off   3:off   4:off   5:off   6:off
postfix         0:off   1:off   2:on    3:on    4:on    5:on    6:off
exim            0:off   1:off   2:off   3:off   4:off   5:off   6:off

run system-switch-mail and choose exim:

sendmail        0:off   1:off   2:off   3:off   4:off   5:off   6:off
postfix         0:off   1:off   2:off   3:off   4:off   5:off   6:off
exim            0:off   1:off   2:on    3:on    4:on    5:on    6:off

run system-switch-mail and choose sendmail:

sendmail        0:off   1:off   2:on    3:on    4:on    5:on    6:off
postfix         0:off   1:off   2:off   3:off   4:off   5:off   6:off
exim            0:off   1:off   2:off   3:off   4:off   5:off   6:off

Please apply this patch.
Comment 1 Dax Kelson 2008-03-06 14:09:13 EST
Created attachment 297087 [details]
Patch to add chkconfig use to system-switch-mail
Comment 2 Dax Kelson 2008-03-06 15:16:24 EST
It would be great if this can get in before the March 11th freeze.
Comment 3 Ngo Than 2008-03-07 11:57:02 EST
it's fixed in 0.5.26-1. Thanks
Comment 4 Dax Kelson 2008-03-15 01:10:06 EDT
Please fix for RHEL5.3 as well.
Comment 5 Ngo Than 2008-03-17 08:42:38 EDT
it's the bug against rawhide. Please don't reopen it since there's someone 
already reported this issue against RHEL-5.x.

Thanks

Note You need to log in before you can comment on or make changes to this bug.