Bug 436366 - [RHEL 5.1] sky2 hw csum failure messages
[RHEL 5.1] sky2 hw csum failure messages
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
i386 Linux
medium Severity medium
: rc
: ---
Assigned To: Andy Gospodarek
Red Hat Kernel QE team
:
Depends On:
Blocks: 445799
  Show dependency treegraph
 
Reported: 2008-03-06 14:45 EST by Flavio Leitner
Modified: 2014-06-29 18:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-15 18:42:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nicbench.tgz - reproducer (12.27 KB, application/octet-stream)
2008-03-06 14:45 EST, Flavio Leitner
no flags Details

  None (edit)
Description Flavio Leitner 2008-03-06 14:45:01 EST
Description of problem:
hw csum error when transmission efficiency is executed.

localhost kernel: <unknown>: hw csum failure.
localhost kernel:
localhost kernel: Call Trace:
localhost kernel:  [<ffffffff80207b92>] skb_copy_and_csum_datagram_iovec+0xc2/0xe6
localhost kernel:  [<ffffffff8001b04c>] tcp_rcv_established+0x320/0x917
localhost kernel:  [<ffffffff8003a966>] tcp_v4_do_rcv+0x2a/0x300
localhost kernel:  [<ffffffff802042f1>] sk_wait_data+0xac/0xbf
localhost kernel:  [<ffffffff8009c164>] autoremove_wake_function+0x0/0x2e
localhost kernel:  [<ffffffff8022c98d>] tcp_prequeue_process+0x65/0x78
localhost kernel:  [<ffffffff8001cb97>] tcp_recvmsg+0x463/0xaf0
localhost kernel:  [<ffffffff8003144e>] sock_common_recvmsg+0x2d/0x42
localhost kernel:  [<ffffffff80043889>] do_sock_read+0xc0/0xcb
localhost kernel:  [<ffffffff80201df1>] sock_aio_read+0x4f/0x5e
localhost kernel:  [<ffffffff8000c8f6>] do_sync_read+0xc7/0x104
localhost kernel:  [<ffffffff8009c164>] autoremove_wake_function+0x0/0x2e
localhost kernel:  [<ffffffff8000b223>] vfs_read+0xde/0x171
localhost kernel:  [<ffffffff8001145b>] sys_read+0x45/0x6e
localhost kernel:  [<ffffffff8005b109>] tracesys+0xd1/0xdc


Version-Release number of selected component (if applicable):
RHEL5.1 GA kernel(2.6.18-53.el5)
kernel-2.6.18-75.el5.gtest.37.i686.rpm

How reproducible:
Always

Steps to Reproduce:
  Edit /etc/modprobe.conf

  alias bond0 bonding
  options bond0 miimon=100 mode=6

  In /etc/sysconfig/network-scripts

  ifcfg-bond0
  DEVICE=bond0
  BOOTPROTO=none
  ONBOOT=yes

  IPADDR=192.168.1.10
  BROADCAST=192.168.1.255
  NETWORK=192.168.1.0
  NETMASK=255.255.255.0

  In /etc/sysconfig/network-scripts
     
  ethX/ethY : sky2 port
  ifcfg-ethX or ifcfg-ethY
  DEVICE=ethX or ethY
  ONBOOT=yes
  BOOTPROTO=none

  USERCTL=no
  MASTER=bond0
  SLAVE=yes

  Do depmod -a

  Do also mkinitrd as root

  Unpack nicbench.tgz, then start network performance tests in the following
  way:
  On client machine do:
  # ./server2

  On server machine do:
  # ./client_ctl2 ./client2 32768 60 xxx.xxx.xxx.xxx yyy.yyy.yyy.yyy

  where xxx.xxx.xxx.xxx and yyy.yyy.yyy.yyy are the client macine
  IP addresses.

Additional info:
* The problem is observed only in the bonding.
* Disabling rx checksumming, the message goes away as it is expected.
Comment 1 Flavio Leitner 2008-03-06 14:45:01 EST
Created attachment 297093 [details]
nicbench.tgz - reproducer
Comment 3 Flavio Leitner 2008-03-06 15:24:07 EST
First time reported here: 
https://bugzilla.redhat.com/show_bug.cgi?id=223631#c36

Andy had request to open another bug to track csum issue here:
https://bugzilla.redhat.com/show_bug.cgi?id=223631#c57

Flavio
Comment 7 RHEL Product and Program Management 2008-07-25 13:05:24 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 9 Ludek Smid 2008-07-25 17:54:45 EDT
Unfortunately the previous automated notification about the
non-inclusion of this request in Red Hat Enterprise Linux 5.3 used
the wrong text template. It should have read: this request has been
reviewed by Product Management and is not planned for inclusion
in the current minor release of Red Hat Enterprise Linux.

If you would like this request to be reviewed for the next minor
release, ask your support representative to set the next rhel-x.y
flag to "?" or raise an exception.

Note You need to log in before you can comment on or make changes to this bug.