Bug 436378 - apt mishandles ">=" Provides:
apt mishandles ">=" Provides:
Product: Fedora
Classification: Fedora
Component: apt (Show other bugs)
All Linux
low Severity urgent
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-06 16:05 EST by Leszek Matok
Modified: 2009-07-14 12:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-07-14 12:11:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Leszek Matok 2008-03-06 16:05:53 EST
As can be seen on event-compat-sysv's example, apt doesn't handle ">=" in
"Provides:" well.

event-compat-sysv provides SysVinit >= 2.83, while initscripts require SysVinit
>= 2.85. rpm and yum handle the situation logically (SysVinit 2.82 wouldn't be
provided by event-compat-sysv, but 2.85 is).

This bug makes apt unusable in rawhide. I went back to using yum because of
this, see what you've done!
Comment 1 Axel Thimm 2008-03-07 00:54:13 EST
I didn't even knew there was a Provides: foo >= xyz syntax. Are you sure it
isn't just a plain Provides: foo = xyz (I didn't check the specfile)?

Maybe it's a new rpm syntax in which case it would need yet another conditional
in apt. Panu will not be amused (OTOH maybe he introduced it in rpm ;).
Comment 2 Leszek Matok 2008-03-07 02:46:46 EST
I'm at work and I don't have my rawhide machine with me at the moment, but
http://koji.fedoraproject.org/koji/rpminfo?rpmID=456144 clearly shows ">=". I
don't think the spec says something else.
Comment 3 Bug Zapper 2008-05-14 01:50:17 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 4 Bug Zapper 2009-06-09 19:42:01 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 5 Bug Zapper 2009-07-14 12:11:38 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.