Bug 436385 - pkg_resources.DistributionNotFound: Paste>=1.3
pkg_resources.DistributionNotFound: Paste>=1.3
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: python-paste (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-06 16:48 EST by Dave Malcolm
Modified: 2016-09-19 22:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-06 17:10:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2008-03-06 16:48:06 EST
Description of problem:
Fresh install of RHEL5, yum install TurboGears

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 TurboGears              noarch     1.0.3.2-7.el5    epel              1.9 M
Installing for dependencies:
 python-cheetah          i386       2.0.1-1.el5      epel              544 k
 python-cherrypy         noarch     2.3.0-3.el5      epel              295 k
 python-configobj        noarch     4.4.0-2.el5      epel              218 k
 python-decoratortools   noarch     1.6-1.el5        epel               26 k
 python-devel            x86_64     2.4.3-19.el5     Updates           3.0 M
 python-formencode       noarch     0.7.1-2.el5      epel              306 k
 python-json             noarch     3.4-3.el5        epel               28 k
 python-kid              noarch     0.9.6-1.el5      epel              190 k
 python-nose             noarch     0.10.0-2.el5     epel              272 k
 python-paste            noarch     1.2.1-1.el5      epel              634 k
 python-paste-deploy     noarch     1.1-1.el5        epel               46 k
 python-paste-script     noarch     1.3.6-1.el5      epel              209 k
 python-protocols        i386       1.0-0.3.a0dev_r2082.el5  epel              209 k
 python-psycopg2         i386       2.0.6-1.el5      epel               89 k
 python-ruledispatch     i386       0.5a0-0.8.svnr2306.el5  epel              254 k
 python-setuptools       noarch     0.6c7-1.el5      epel              485 k
 python-simplejson       i386       1.7.3-1.el5      epel               82 k
 python-sqlalchemy       noarch     0.3.11-1.el5     epel              1.2 M
 python-sqlite2          i386       1:2.3.3-1.el5    epel               83 k
 python-sqlobject        noarch     0.9.2-1.el5      epel              473 k
 python-tgfastdata       noarch     0.9a6-6.el5      epel               22 k
 python-turbocheetah     noarch     1.0-3.el5        epel              9.2 k
 python-turbojson        noarch     1.1.2-3.el5      epel               14 k
 python-turbokid         noarch     1.0.4-1.el5      epel               12 k

Transaction Summary
=============================================================================
Install     25 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

etc

Try to run "tg-admin":
Traceback (most recent call last):
  File "/usr/bin/tg-admin", line 5, in ?
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 2564, in ?
    for dist in working_set.resolve(
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 524, in resolve
    raise DistributionNotFound(req)  # XXX put more info here
pkg_resources.DistributionNotFound: Paste>=1.3

Looking in
/usr/lib/python2.4/site-packages/PasteScript-1.3.6-py2.4.egg-info/requires.txt
I see:
Paste>=1.3

So it looks like the latest EPEL version of python-paste-script egg-requires a
more recent version of python-paste than it rpm-requires, if that makes sense.

Version-Release number of selected component (if applicable):
as above
Comment 1 Luke Macken 2008-03-06 17:10:45 EST
I built python-paste-1.4.2-1.el5 yesterday, which should resolve this issue. 
It's currently in testing:

http://download.fedora.redhat.com/pub/epel/testing/5/i386/python-paste-1.4.2-1.el5.noarch.rpm
Comment 2 Dave Malcolm 2008-03-06 17:16:54 EST
Thanks; with that RPM, tg-admin now works

Note You need to log in before you can comment on or make changes to this bug.