Bug 43639 - gnorpm as root causes XML-CRITICAL error for Web Find; doesn't work.
gnorpm as root causes XML-CRITICAL error for Web Find; doesn't work.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gnorpm (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Alexander Larsson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-05 20:19 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-02 12:18:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-06-05 20:19:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
If logged in as root, loading gnorpm and then doing Web Find causes:
XML-CRITICAL **: Document is empty
XML-CRITICAL **: Start tag expect, '<' not found

Does NOT happen if logged in as another user, but then if not root,
installs usually fail...

How reproducible:
Always

Steps to Reproduce:
1. Start gnorpm from bash prompt as root (or gnorpm-auth) or via GNOME menu 
2. Select Web find
3. Voila, XML-CRITICAL errors printed on host shell, and only a template is
displayed in the web-find window.

I suspect that this is more of a local issue, but I cannot find what the
conflict is. It all works fine if I am non-root, do a web find, and just
select DOWNLOAD.  Then I have to shell in as root to install the RPM...	
	

Actual Results:  XML-CRITICAL errors printed to host window (if started
from bash prompt)

Expected Results:  Successful gnorpm web-find.	

Additional info:

Some version information:
[root@mars /root]# rpm -qa | grep gnorpm
gnorpm-0.96-1
[root@mars /root]# rpm -qa | grep xml
libxml-devel-1.8.10-1
python-xmlrpc-1.4-1
libxml-1.8.10-1
[root@mars /root]# rpm -qa | grep gtk
gtk+-1.2.9-4
rep-gtk-libglade-0.15-3
gtk-engines-0.10-12
pygtk-libglade-0.6.6-7
rep-gtk-gnome-0.15-3
pygtk-0.6.6-7
rep-gtk-0.15-3
gtk+-devel-1.2.9-4
Comment 1 Alexander Larsson 2001-08-02 11:51:26 EDT
Very strange, It works for me. 
Could you try blowing away /home/root/.gnome/gnorpm* and try again?
Comment 2 Need Real Name 2001-08-02 12:13:27 EDT
Odder and odder.

At the moment, I'm not sitting at the console, so instead, I telnet'd in and 
X'd back to my PC.

Went through the same steps I gave above, but this time it works.

It *has* been two months since I reported this, and I don't think I've tried 
again since then, so it's possible up2date or my own RPM installs fixed 
something.

I'll try this again when I get back, and post the results.

Comment 3 Alexander Larsson 2001-08-02 12:17:59 EDT
It's completely possible that there was some snafu at the redhat ftp site.
Comment 4 Alexander Larsson 2001-08-23 14:26:56 EDT
I believe this was due to ftp site snafu. I'm closing this NOTABUG. If you still
get it, please reopen.
Comment 5 Need Real Name 2001-11-08 11:53:30 EST
I've had this same problem on & off for a year or so (out-of-box RH7.1 has no
problems).

This **was** working prior to an up2date run 30th Oct 2k1

please re-open as BUG
Comment 6 Alexander Larsson 2001-11-08 18:03:13 EST
This is not a bug in gnorpm. It is a problem with the files on the ftp servers.
It has been "fixed" once, but nobody seems to be maintaining that parts anymore.

Note You need to log in before you can comment on or make changes to this bug.