Bug 436393 - Conflict between i386 and x86_64 rpms
Conflict between i386 and x86_64 rpms
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 518075
  Show dependency treegraph
 
Reported: 2008-03-06 17:13 EST by Marco Pesenti Gritti
Modified: 2009-08-18 14:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 518075 (view as bug list)
Environment:
Last Closed: 2008-04-18 05:23:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed /usr/bin/xulrunner replacement (1.56 KB, text/plain)
2008-04-16 17:05 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Marco Pesenti Gritti 2008-03-06 17:13:19 EST
Here is the yum output:

[root@localhost ~]# yum install xulrunner-devel

Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package xulrunner-devel.x86_64 0:1.9-0.beta4.34.nightly20080304.fc9 set to
be updated
--> Processing Dependency: nspr-devel >= 4.6.99 for package: xulrunner-devel
--> Processing Dependency: nss-devel >= 3.11.99 for package: xulrunner-devel
---> Package xulrunner-devel.i386 0:1.9-0.beta4.34.nightly20080304.fc9 set to be
updated
--> Processing Dependency: libxul.so for package: xulrunner-devel
--> Processing Dependency: libmozjs.so for package: xulrunner-devel
--> Processing Dependency: libxpcom.so for package: xulrunner-devel
--> Running transaction check
---> Package xulrunner.i386 0:1.9-0.beta4.34.nightly20080304.fc9 set to be updated
--> Processing Dependency: libhunspell.so.1 for package: xulrunner
---> Package nspr-devel.i386 0:4.7.0.99.1-2.fc9 set to be updated
---> Package nss-devel.i386 0:3.11.99.4-1.fc9 set to be updated
--> Running transaction check
---> Package hunspell.i386 0:1.2.1-5.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 xulrunner-devel         i386       1.9-0.beta4.34.nightly20080304.fc9 
development       3.4 M
 xulrunner-devel         x86_64     1.9-0.beta4.34.nightly20080304.fc9 
development       3.4 M
Installing for dependencies:
 hunspell                i386       1.2.1-5.fc9      development       186 k
 nspr-devel              i386       4.7.0.99.1-2.fc9  development       112 k
 nss-devel               i386       3.11.99.4-1.fc9  development       226 k
 xulrunner               i386       1.9-0.beta4.34.nightly20080304.fc9 
development       9.3 M

Transaction Summary
=============================================================================
Install      6 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total size: 17 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /usr/bin/xulrunner from install of
xulrunner-1.9-0.beta4.34.nightly20080304.fc9.i386 conflicts with file from
package xulrunner-1.9-0.beta4.34.nightly20080304.fc9.x86_64

Error Summary
-------------
Comment 1 Michal Jaegermann 2008-03-18 15:08:13 EDT
The main problem is that /usr/bin/xulrunner is a symlink to
either /usr/lib64/xulrunner-1.9pre/xulrunner or, depending
on a architecture, /usr/lib/xulrunner-1.9pre/xulrunner.  These
are different links hence a conflict.

A target of that link is a script again, similar in a spirit to a common
for x86_64 and i386 architectures script /usr/bin/firefox (thus
firefox.i386 and firefox.x86_64 can be installed without conflicts).
Even if rewriting xulrunner script in a similar manner would be
not a good idea, for whatever reasons, then replacing /usr/bin/xulrunner
link with an "architecturaly smart" script which execs the next level
should solve the issue.  That initial piece of a code which
establishes MOZ_LIB_DIR in /usr/bin/firefox could be lifted from
there nearly literally after minor adjustments.
Comment 2 Michal Jaegermann 2008-04-16 17:05:51 EDT
Created attachment 302673 [details]
proposed /usr/bin/xulrunner replacement

If there are no other takers then it looks like that something like that,
cribbed from fragments of /usr/bin/firefox, will work as /usr/bin/xulrunner
without causing conflicts between multilib packages.
Comment 4 Christopher Aillon 2008-04-17 23:21:31 EDT
Michal, please provide it in patch format.  You can do this with the following
command:

diff -u $OLD_FILE $NEW_FILE
Comment 5 Martin Stransky 2008-04-18 02:32:52 EDT
It's a new file so patch is not necessary :)
Comment 6 Martin Stransky 2008-04-18 05:23:56 EDT
added to xulrunner-1.9-0.55.beta5.fc9

Note You need to log in before you can comment on or make changes to this bug.