Bug 436404 - X server gets unhappy on policy update with selinux X bits
X server gets unhappy on policy update with selinux X bits
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: SELinux
: 436819 (view as bug list)
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-03-06 17:43 EST by Jeremy Katz
Modified: 2008-03-13 16:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 16:46:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2008-03-06 17:43:03 EST
When doing a livecd creation (and earlier, I think I hit this doing a yum
update), when the policy was loaded, the X server went unhappy and several apps
crashed with a BadValue error.  This seems bad.
Comment 2 Daniel Walsh 2008-03-06 18:26:12 EST
Are you sure you are up2date.  There was some similar problems on an x release a
week or so ago.
Comment 3 Jeremy Katz 2008-03-06 19:23:28 EST
The crash I had earlier wasn't fully updated, I had last updated it about a week
ago.

But the livecd creation was after just updating my workstation to current
rawhide, rebooting and making sure I could still build live images.  So it was
definitely current.  Also, we need to be very very very sure that reloading
policy/updating doesn't kill the X server as doing so is a good way to lead to
significant problems on people's systems.
Comment 4 Adam Jackson 2008-03-12 16:56:57 EDT
*** Bug 436819 has been marked as a duplicate of this bug. ***
Comment 5 Adam Jackson 2008-03-13 16:46:01 EDT
Sorted in 1.4.99.901-8.  X-SELinux will be off by default in F9.

Note You need to log in before you can comment on or make changes to this bug.