Bug 436419 - Panic on NFSRoot/iscsi systems
Panic on NFSRoot/iscsi systems
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5
All Linux
high Severity high
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-06 21:05 EST by Greg Nichols
Modified: 2008-09-12 12:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-12 12:56:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
HTS results for x86_64 NFSroot client/server with iSCSI swap (578.33 KB, application/octet-stream)
2008-04-30 19:58 EDT, Jonathan Lim
no flags Details

  None (edit)
Description Greg Nichols 2008-03-06 21:05:55 EST
Description of problem:

HTS results for x86_64 with NFSroot and using iSCSI for swap

Attached are the results from running HTS on an x86_64 system
with NFSroot and using iSCSI for swap:

  1. NFSroot and swap (512MB) are provided from another x86_64
     system.  Both are running 2.6.18-53.el5 (RHEL5.1-GA).

  2. The network test for eth0 and eth1 are disabled because
     any interruption to NFS causes the system to hang.

  3. After running HTS, rpm fails to run with the following
     error:

       rpmdb: PANIC: fatal region error detected; run recovery
       error: db4 error(-30977) from dbenv->open: DB_RUNRECOVERY: Fatal error,
run database recovery
       error: cannot open Packages index using db3 -  (-30977)
       error: cannot open Packages database in /var/lib/rpm
Comment 6 Jonathan Lim 2008-04-30 19:56:38 EDT
I installed RHEL5.2-Snapshot6 (2.6.18-90.el5) on two x86_64 systems, one as
the NFSroot server and the other as the client, using iSCSI for swap.  I then
installed hts-5.2-12.el5 on both systems; with the exception of the eth0 and
eth1 network tests which were disabled, hts ran to completion without error.
Comment 7 Jonathan Lim 2008-04-30 19:58:47 EDT
Created attachment 304283 [details]
HTS results for x86_64 NFSroot client/server with iSCSI swap

Note You need to log in before you can comment on or make changes to this bug.