Bug 436424 - Cacti inaccessible after upgrade to 0.8.7b
Cacti inaccessible after upgrade to 0.8.7b
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: cacti (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-06 22:10 EST by George Notaras
Modified: 2008-06-17 17:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-17 17:36:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Notaras 2008-03-06 22:10:50 EST
Description of problem:
The upgrade procedure cannot be performed after upgrading to version
0.8.7b-1.fc7 through yum.

Displayed error:

  Invalid PHP_SELF Path

Version-Release number of selected component (if applicable):
0.8.7b-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. Upgrade cacti through yum
2. Try to access your cacti website with a web browser.
3.

Additional info:
-

Workaround:

By default, an alias of the cacti directory (/usr/share/cacti/) is set in
/etc/httpd/conf.d/cacti.conf, which points to cacti's installation directory
(/usr/share/cacti/):

  Alias /cacti    /usr/share/cacti

Cacti will be accessible if a symlink is created in the DocumentRoot of the
virtualhost context that will be used to access cacti through a web browser.
This could be the DocumentRoot of the main server as well.

  ln -s /usr/share/cacti cacti

Note that the FollowSymLinks option should be enabled for that particular context.
Comment 1 Mike McGrath 2008-03-06 22:23:53 EST
Is anyone else seeing this?  Have you been able to re-create this on say a
fedora 7 live CD?  It just sounds like a configuration error.
Comment 2 George Notaras 2008-03-07 18:34:38 EST
It may sound like a config error, but it's most probably a bug that should be
investigated, since it completely blocks access to cacti.

I can confirm that the same behaviour occurs in Fedora 8 using the same version
of cacti.

I guess someone should have tested cacti 0.8.7b before releasing it in the main
repos.
Comment 3 Mike McGrath 2008-03-07 18:46:14 EST
It was tested, in fact I can't recreate it.  and considering its been out for 3
weeks I'd think someone else would have noticed.

I ask again.  Have you been able to re-create this on something like one of
Fedora's live CD's?  Many configurations don't rely on DocumentRoot at all (none
of my services do), and we've never had a link there before.

Is it possible you upgraded from a cacti package that wasn't initially from Fedora?
Comment 4 George Notaras 2008-03-07 19:08:31 EST
I haven't tried a LiveCD as I do not have any Fedora installation media at the
moment. Also, I haven't been able to make a clean installation of cacti. I will
try to test it in one of the following days and report back.

What I have tried so far was the following:

  1. Upgraded cacti in F7, which resulted in the aforementioned error.
  2. Upgraded OS to F8, which eventually updraged the F7 cacti package to the
one made for F8 (Always refering to cacti package version 0.8.7b-1). The error
message continued to appear.

I've used yum to manage the cacti installation/upgrade. I have neither performed
a manual installation/upgrade nor I have modified the core cacti files in any way.
Comment 5 Mike McGrath 2008-03-07 21:37:23 EST
Interesting, so it seems a google search for your first error yields only cacti
results so you're not alone but it seems to be happening to lots of people over
lots of releases.  I'm going to do some more research to try to recreate it. 

It could be a config thing, a cacti thing, or even a php thing.  Did you happen
to upgrade php at the same time is cacti?  What is the exact version of php you
are running and also can you give me the output of rpm -qV cacti?
Comment 6 Mike McGrath 2008-03-07 21:53:15 EST
Another question, do you have selinux enabled?

/usr/sbin/getenforce
Comment 7 George Notaras 2008-03-07 22:19:34 EST
Yes, I have searched google too, but i found many different reports and
solutions about the issue.

I also found some time and did a clean installation of cacti 0.8.7b on Fedora 8
with yum. The clean installation works and is error-free.

I tried with SELinux in enforcing and permissive modes. It works. I finally
assume that the issue has been caused by cacti's internal upgrade script.

PHP version:

# php -v
PHP 5.2.4 (cli) (built: Oct 16 2007 09:13:35) 
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with eAccelerator v0.9.5.2, Copyright (c) 2004-2006 eAccelerator, by
eAccelerator

# rpm -qV cacti
S.5....T c /etc/cacti/db.php
S.5....T c /etc/cron.d/cacti
S.5....T c /etc/httpd/conf.d/cacti.conf
S.5....T c /etc/logrotate.d/cacti
S.5....T   /var/log/cacti/cacti.log

As you can see no core cacti files have been modified in any way.
Comment 8 Mike McGrath 2008-03-07 22:50:33 EST
Do you remember what version you upgraded from initially?
Comment 9 Mike McGrath 2008-03-07 22:53:21 EST
OH, and another thing, can you re-create the problem and run make sure that

"error_reporting  =  E_ALL"

is set in your php.ini file (requires http restart)

See if we can get anything else in the /var/log/httpd/error_logs or to the screen.
Comment 10 George Notaras 2008-03-08 15:20:31 EST
The package upgrades happened in the following order:

  1. cacti-0.8.7a-1.fc7
  2. cacti-0.8.7b-1.fc7
  3. cacti-0.8.7b-1.fc8

"error_reporting" is set to E_ALL, but, unfortunately, apache's error_logs (main
server's and virtual hosts') do not contain any related errors.

Taking into account that some of the proposed fixes in the cacti forums contain
modifications of the core files, I guess the problem is directly related to
cacti itself. This is a wild guess though. I'll keep checking the cacti forums
for any new info and report back in the future.
Comment 11 Bug Zapper 2008-05-14 11:22:07 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Bug Zapper 2008-06-16 23:03:17 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 13 George Notaras 2008-06-17 11:57:42 EDT
I re-open the bug for fedora 8.

I have installed cacti directly from the upstream distribution package and I was
able to always re-produce the bug.
Comment 14 Mike McGrath 2008-06-17 12:58:43 EDT
FWIW, unless we can find someone else who has this problem that I haven't ever
been able to reproduce I'm going to have to assume that George is doing
something unique that is causing this.

Seeing as how long its been open I have no problem leaving it open but it seems
no one else in EPEL or Fedora has seen this issue.
Comment 15 George Notaras 2008-06-17 16:38:39 EDT
It is absolutely fine with me to permanently close the bug. I reopened it
because the ticket had been closed automatically by the system without any human
intervention.

Regarding the issue itself, I have encountered the same problem again in F8 by
using both the fedora rpm package and the upstream cacti package. Also, the fact
that there are several similar reports in the cacti forums means that it could
be a bug of the 0.8.7b release of Cacti.

It definitely is not a problem of the fedora package.

Please, do whatever is appropriate.
Comment 16 Mike McGrath 2008-06-17 17:36:37 EDT
<nod>

So how about this.  I'll close the bug and keep my eyes open in case someone
else opens it.

Note You need to log in before you can comment on or make changes to this bug.