Bug 436439 - The argument 'group' of builtin 'newgrp' should be optional.
The argument 'group' of builtin 'newgrp' should be optional.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tcsh617 (Show other bugs)
5.1
i686 Linux
low Severity low
: rc
: ---
Assigned To: Vojtech Vitek
BaseOS QE - Apps
: ManPageChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 02:19 EST by Cai Xianchao
Modified: 2015-03-04 18:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Prior to this update, the tcsh(1) man page inaccurately stated that it is mandatory to use the "group" option when using the "newgrp" built-in command. The corrected statement now says that using "group" is optional.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 04:49:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
This is a patch fixing the bug. (447 bytes, patch)
2008-03-07 02:19 EST, Cai Xianchao
no flags Details | Diff

  None (edit)
Description Cai Xianchao 2008-03-07 02:19:59 EST
Description of problem:
The description of builtin "newgrp" is "newgrp [-] group", it shows that
argument "group" is necessary, but actually it is optional. In newgrp(1),
"group" is optional too.

Version-Release number of selected component (if applicable):
tcsh-6.15.00

How reproducible:


Steps to Reproduce:
1.[test@localhost ~]$newgrp
2.[test@localhost ~]$echo $?
0
  
Actual results:
It is executed successfully.

Expected results:
An error message is outputed and the return value is not 0.

Additional info:
Comment 1 Cai Xianchao 2008-03-07 02:19:59 EST
Created attachment 297148 [details]
This is a patch fixing the bug.
Comment 2 RHEL Product and Program Management 2011-01-11 14:58:04 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2011-01-12 10:14:17 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 4 Vojtech Vitek 2011-01-17 10:31:43 EST
Will be proposed to upstream.
Comment 9 Vojtech Vitek 2011-04-15 12:41:12 EDT
Proposed to upstream: http://bugs.gw.com/view.php?id=119
Comment 10 Vojtech Vitek 2011-04-18 04:27:04 EDT
Accepted by upstream (tcsh 6.17.07b).
Comment 11 Branislav Náter 2011-06-22 02:43:56 EDT
Bugfix was successfully verified on tcsh617-6.17-5.el5 package.

Group parameter for newgrp builtin is new marked as optional (newgrp [-] [group]).
Comment 12 Miroslav Svoboda 2011-07-01 17:40:41 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update, the tcsh(1) man page inaccurately stated that it is mandatory to use the "group" option when using the "newgrp" built-in command. The corrected statement now says that using "group" is optional.
Comment 13 errata-xmlrpc 2011-07-21 04:49:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1072.html
Comment 14 errata-xmlrpc 2011-07-21 08:08:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1072.html

Note You need to log in before you can comment on or make changes to this bug.