Bug 436454 - RFE patch to swap rdesktop mouse buttons
RFE patch to swap rdesktop mouse buttons
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rdesktop (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jon Disnard
Fedora Extras Quality Assurance
: FutureFeature, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 06:00 EST by Fred New
Modified: 2017-03-15 14:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-15 14:39:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Adapted patch to permit the use of -l to swap mouse buttions (2.04 KB, patch)
2008-03-07 06:00 EST, Fred New
no flags Details | Diff
Mouse button switching patch adapted for rdesktop-1.6.0 (2.06 KB, patch)
2008-05-19 07:21 EDT, Fred New
no flags Details | Diff
The same as the previous patch with an update to the man page, too (2.73 KB, patch)
2008-05-19 07:47 EDT, Fred New
no flags Details | Diff

  None (edit)
Description Fred New 2008-03-07 06:00:14 EST
Description of problem:
Attached is an adapted patch from the rdesktop SourceForge site to permit the
use of the "-l" argument to reverse mouse buttons.  (I guess it's -l as in
left-handed.)  This is to work around a problem where I have configured a
left-handed mouse on a remote desktop (to match a left-handed mouse on a local
Windows XP workstation).  The problem arises because the Windows remote desktop
and the Linux rdesktop work differently when it comes to propagating mouse
button signals.

Version-Release number of selected component (if applicable):
rdesktop-1.5.0-4.fc8

How reproducible:
Always

Steps to Reproduce:
1. Set a left-handed mouse on a remote desktop.
2. rdesktop to that remote desktop
  
Actual results:
Mouse buttons are reversed - If you have a left-handed mouse locally, the remote
mouse is right-handed.  If you have a right-handed mouse locally, the remote
mouse is left-handed.

Expected results:
If a local mouse is right-handed, the remote mouse should work the same, etc. 
OR I should be able to tell rdesktop that I want to swap mouse buttons (which is
what this patch does).

Additional info:
I have adapted the patch by un-reversing it.

I suppose the man page should include information about the -l argument if this
patch is adapted.  Perhaps the following would be sufficient:

     -l Swap mouse buttons.  Useful if you have configured a left-handed mouse
on the remote system.

More information available at
http://sourceforge.net/tracker/index.php?func=detail&aid=1706977&group_id=24366&atid=381347
http://sourceforge.net/tracker/index.php?func=detail&aid=1585331&group_id=24366&atid=381349

Since we're already pretty well into the F9 cycle, maybe we can get upstream to
include it before we start on F10.  But the patch is already more than a year
old, so maybe they are trying to come up with a better solution.
Comment 1 Fred New 2008-03-07 06:00:14 EST
Created attachment 297167 [details]
Adapted patch to permit the use of -l to swap mouse buttions
Comment 2 Fred New 2008-05-19 07:21:49 EDT
Created attachment 305926 [details]
Mouse button switching patch adapted for rdesktop-1.6.0

rdesktop-1.6.0 does a good job of matching mouse button behaviour of the
Microsoft Remote Desktop, but we can do better than Microsoft.	I have
- Fedora 8 with a left-handed mouse,
- Windows XP with a left-handed mouse and
- Fedora 9 with a right-handed mouse.
With rdesktop-1.6.0, the left-handed desktops work the same, but when I use
rdesktop-1.6.0 from the right-handed Fedora 9 desktop, my remote desktop works
as if I have a left-handed mouse.  (This is because I have set up my
preferences on the remote server to accommodate my Windows XP workstation.)  My
fingers get confused :-).

As with my previous patch, I didn't include a patch for the man page
documenting the "-l" parameter getting added.  I can work on that if someone
shows an interest in this RFE.
Comment 3 Fred New 2008-05-19 07:47:04 EDT
Created attachment 305931 [details]
The same as the previous patch with an update to the man page, too

It wasn't very hard to include additional text for the man page.  I hope the
text is acceptable.
Comment 4 Matthias Clasen 2008-10-20 13:02:50 EDT
This patch adds a new commandline option. Before accepting such a thing, we need to be very sure that upstream will take the same route, otherwise we are doomed to support this extra option forever...
Comment 5 Fred New 2008-10-20 15:12:25 EDT
I agree.  Feel free to sit on this or close it.  I'll sign up for yet another upstream user ID and submit it there.
Comment 7 Fedora Admin XMLRPC Client 2014-01-06 15:35:20 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Jon Disnard 2017-03-15 14:39:40 EDT
This needs to go upstream. closing out.

Note You need to log in before you can comment on or make changes to this bug.