Bug 436457 - kernel-debuginfo not available in RHN
kernel-debuginfo not available in RHN
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: distribution (Show other bugs)
4.6
All Linux
low Severity low
: rc
: ---
Assigned To: RHEL Product and Program Management
Daniel Riek
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 06:33 EST by Gavin White
Modified: 2008-08-25 12:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-25 12:30:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gavin White 2008-03-07 06:33:17 EST
Description of problem:

If I run `up2date -i systemtap` a RHEL4.6 x86_64 machine, it will install
systemtap from the standard channels. However, systemtap requires the
kernel-debuginfo package to run, and this package is not available from RHN.
Could you make kernel-debuginfo available in RHN/satellite so that systemtap is
actually useable, without my having to google the kernel-debuginfo package from
some nonstandard source?

How reproducible:

Very

Steps to Reproduce:
1. On a fresh RHEL4.6 install, run `up2date -i systemtap`
2. Try running a stap query
  
Actual results:

It will fail because kernel-debuginfo is not available.

Expected results:

the stap query should work

Additional info:
Comment 1 Frank Ch. Eigler 2008-03-07 07:55:31 EST
I completely sympathize, but this is a larger (and older) RHEL/RHN issue,
and not one that the systemtap group can fix.  See bug# 435944.
Comment 3 RHEL Product and Program Management 2008-08-25 12:30:47 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.