Bug 436500 - only-non-binary-in-usr-lib error should not apply to subpackages
only-non-binary-in-usr-lib error should not apply to subpackages
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 11:39 EST by Thomas Fitzsimmons
Modified: 2008-07-25 13:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 13:30:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Fitzsimmons 2008-03-07 11:39:25 EST
Description of problem:

rpmlint is flagging IcedTea's src subpackage with the only-non-binary-in-usr-lib
error.

Version-Release number of selected component (if applicable):

rpmlint-0.82-3.fc9

How reproducible:

Always.

Steps to Reproduce:
1. Build IcedTea RPMs: https://bugzilla.redhat.com/show_bug.cgi?id=433070
2. rpmlint $rpm_topdir/RPMS/i386/java-1.6.0-openjdk-src-1.6.0.0-0.1.b06.fc8.i386.rpm

Actual results:

java-1.6.0-openjdk-src.i386: E: only-non-binary-in-usr-lib

Expected results:

No output.  This is a subpackage, split out purely for size purposes.  It seems
arbitrary to say that because src.zip happens to be architecture-independent,
and happens to be the only file in the -src subpackage, that it needs to go in
/usr/share.  src.zip needs to in $JAVA_HOME so that IDEs can locate it properly.
Comment 1 Ville Skyttä 2008-03-07 14:25:19 EST
Apart for some very specific checks on installed packages, the unit of work for
rpmlint is one package, and it has no way of knowing whether something is a
subpackage or not.  I don't have any ideas right how to address this issue apart
from just ignoring rpmlint's message.  Others?
Comment 2 Bug Zapper 2008-05-14 01:51:27 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Red Hat Bugzilla 2008-07-24 21:04:16 EDT
Adding patrickm@redhat.com to the cc list as the manager of the disabled user fitzsim@redhat.com who reported this bug
Comment 4 Ville Skyttä 2008-07-25 13:30:52 EDT
Closing due to lack of feedback/ideas.

Note You need to log in before you can comment on or make changes to this bug.