Bug 436504 - xmoto-edit can't start xmoto
Summary: xmoto-edit can't start xmoto
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xmoto-edit
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 438156
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-07 16:54 UTC by Vegard Nossum
Modified: 2008-06-10 16:44 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2008-06-10 16:44:18 UTC


Attachments (Terms of Use)

Description Vegard Nossum 2008-03-07 16:54:18 UTC
Description of problem:

When pressing F4 in the xmoto-edit program, the game itself is not started.

Version-Release number of selected component (if applicable): xmoto 0.3.4

How reproducible: Always

Steps to Reproduce:
1. Start xmoto-edit
2. Press F2 (save)
3. Press F4 (play)
  
Actual results:
syntax error : Invalid option "-level"
X-Moto 0.3.4
usage:  xmoto [options]
options:
...

Expected results:
(xmoto playing the level in question)

Additional info:
There is an option --level which I believe should be passed instead of -level to
xmoto.

Comment 1 Gwyn Ciesla 2008-03-07 17:43:18 UTC
xmoto man page gives the option as -level, not -level.  xmoto-edit is using the
-level flag.  I'll have to test this myself when I get back to my main machine,
with GUI access.

Comment 2 Gwyn Ciesla 2008-03-08 02:43:12 UTC
Please test the new patched kawhide build in koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=42141

Comment 3 Vegard Nossum 2008-03-08 09:12:15 UTC
Using xmoto-edit-0.2.4-13.fc9.i386.rpm, xmoto now starts when I press F4.
However, the level is still not playable, because I get only a dialog message:

"Level 'noname' cannot be loaded" [OK]

Note that I did press F2 (Save) before F4 (Play), and the level editor printed this:

"Saving level in Levels/noname.lvl"

And the file is indeed saved to ~/.xmoto/Levels/noname.lvl, but no combination
of absolute path, Levels/ prefix, or .lvl postfix will allow me to play the level.

Unfortunately, I cannot install the .fc9 package for xmoto because this would
require me to upgrade libc as well.

Comment 4 Gwyn Ciesla 2008-03-08 13:44:33 UTC
Crud. I get that too.  Anyway, installing the fc9 xmoto wouldn't likely help.

I took a peek at the upstream site, and it looks like xmoto-edit is officially
deprecated in favor of inksmoto, their inkscape plugin, which looks pretty slick
and supports pretty much everything xmoto-edit does.  I'll be packaging it soon,
and I can even place a link in this bug to a preview to an fc8 rpm if you like.
Sound ok?  I'd rather not spend too much time fixing something that's obsolete.

Comment 5 Gwyn Ciesla 2008-03-19 13:58:21 UTC
See the inksmoto review. . . feel free to dl/l the SRPM and build it for
yourself to test.

https://bugzilla.redhat.com/show_bug.cgi?id=438156

Comment 6 Gwyn Ciesla 2008-05-15 20:07:48 UTC
FYI, inksmoto's review was just approved, I'll let you know when it's built and
pushed for f8.

Comment 7 Gwyn Ciesla 2008-05-16 16:32:57 UTC
inksmoto is built in koji for devel, f9 and f8, and bodhi requests to push made.

Comment 8 Gwyn Ciesla 2008-06-10 16:44:18 UTC
Followed package EOL procedure.


Note You need to log in before you can comment on or make changes to this bug.