Bug 436528 - Documented token doesn't work for admin-server password.conf file
Documented token doesn't work for admin-server password.conf file
Status: CLOSED DUPLICATE of bug 476910
Product: Red Hat Directory Server
Classification: Red Hat
Component: Doc - administration-guide (Show other bugs)
8.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Deon Ballard
Content Services Development
https://www.redhat.com/docs/manuals/d...
: Documentation
Depends On:
Blocks: 240316
  Show dependency treegraph
 
Reported: 2008-03-07 13:48 EST by Chris Evich
Modified: 2009-08-19 23:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-19 11:27:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Evich 2008-03-07 13:48:19 EST
Description of problem:
Section "11.4.4" step #2 lists the default token for the admin server as
"Internal (Software) Token".  The "Manage Certificates" window in the console
for the administration server lists "internal (Software)".  However, I had to
specify the token as just "internal" in /etc/dirsrv/admin-serv/password.conf in
order for it to start w/o prompting me.  

Version-Release number of selected component (if applicable):
Found in RHDS 8

How reproducible:
Very

Steps to Reproduce:
1. Specify the token as "Internal (Software) Token" in
/etc/dirsrv/admin-serv/password.conf
2. restart the admin server
  
Actual results:
# service dirsrv-admin start
Starting dirsrv-admin: 
Please enter password for "internal" token:


Expected results:
# service dirsrv-admin start
Starting dirsrv-admin: 
                                                           [  OK  ]

Additional info:
Specifying the token as "Internal (Software) Token" for the directory server's
pin.txt file (as per section 11.4.3 works properly.
Comment 1 Deon Ballard 2009-01-19 11:26:54 EST
You're right; the pin.txt example is wrong. 

The correction is live on rh.com for the 8.0 admin guide and have been carried
over into the 8.1 drafts.
http://www.redhat.com/docs/manuals/dir-server/ag/8.0/Managing_SSL-Starting_the_Server_with_SSL_Enabled.html#Starting_the_Server_with_SSL_Enabled-Enabling_SSL_in_the_DS_Admin_Server_and_Console
Comment 2 Deon Ballard 2009-01-19 11:27:38 EST
I am closing this bug as a duplicate of bug 476910.

*** This bug has been marked as a duplicate of bug 476910 ***

Note You need to log in before you can comment on or make changes to this bug.