Bug 436555 - KVM switch blocks monitor detection
KVM switch blocks monitor detection
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 16:15 EST by Jerry James
Modified: 2008-03-17 11:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 11:27:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf that works (885 bytes, text/plain)
2008-03-07 16:15 EST, Jerry James
no flags Details
Xorg.0.log with the xorg.conf that works (43.49 KB, text/plain)
2008-03-07 16:16 EST, Jerry James
no flags Details

  None (edit)
Description Jerry James 2008-03-07 16:15:23 EST
Description of problem:
I have a server room with a single keyboard, mouse, and monitor.  A KVM switch
controls the machine with which those devices communicate.  With both Fedora 7
and Fedora 8, the monitor is not detected properly when the KVM switch is set on
the target machine.  I get a resolution of 800x600 and an invisible mouse
pointer.  I have to explicitly set the horizontal and vertical refresh rates of
the monitor, and list the modes I want in xorg.conf.  I also have to turn off
the hardware cursor to get a visible mouse pointer.  If I plug the monitor
directly into the target machine, detection works, so the KVM switch is playing
a role here somehow.

I am attaching the xorg.conf I have to use, as well as an Xorg.0.log when that
xorg.conf is in use.  You'll note that I also set the TargetRefresh option. 
That is because without it, I do get 1280x1024, but at a suboptimal refresh rate
(I've forgotten what).

I'm happy to mess around with the settings if there are things you would like me
to try.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.3.0.0-42.fc8

How reproducible:
Always

Steps to Reproduce:
1. Set the KVM switch to the target machine
2. Boot the machine
  
Actual results:
800x600 resolution and an invisible mouse pointer

Expected results:
1280x1024 resolution and a visible mouse pointer

Additional info:
Comment 1 Jerry James 2008-03-07 16:15:23 EST
Created attachment 297253 [details]
xorg.conf that works
Comment 2 Jerry James 2008-03-07 16:16:03 EST
Created attachment 297254 [details]
Xorg.0.log with the xorg.conf that works
Comment 3 Adam Jackson 2008-03-12 16:44:43 EDT
There's really not a lot we can do about this.  The KVM is physically preventing
us from asking the monitor what it can do.
Comment 4 Jerry James 2008-03-13 16:01:20 EDT
Well, that's what I thought.  But in this thread:

https://www.redhat.com/archives/fedora-devel-list/2008-February/msg02454.html
https://www.redhat.com/archives/fedora-devel-list/2008-March/msg00046.html

Matej Cepl insisted that this behavior is a bug and asked me to file it as such.
 So I did.  Maybe you should assign the bug to Matej. :-)
Comment 5 Matěj Cepl 2008-03-17 11:27:54 EDT
I should deserve it ... Sorry.

Note You need to log in before you can comment on or make changes to this bug.