Bug 436566 - virt-manager fails to display shared physical device choice after OS update.
virt-manager fails to display shared physical device choice after OS update.
Status: CLOSED DUPLICATE of bug 436362
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.1
x86_64 Linux
low Severity urgent
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 17:33 EST by Travis Lawall
Modified: 2009-12-14 16:16 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 17:45:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Travis Lawall 2008-03-07 17:33:23 EST
Description of problem:

    virt-manager fails to display choices for shared physical device after
running updates.

Version-Release number of selected component (if applicable):

    RedHat Enterprise Linux version 5

How reproducible:

    Has happend 3 time now.  Twice to me and once to a coworker.

Steps to Reproduce:
 

1.) Install RedHat 5.1 with xen/virtualization on a machine.

2.) Register the system.

3.) Start virt-manager. 

4.) Go through the dialogs to create a new virtual machine. On the "Connect to
host network" dialog, virt-manager will correctly detect and display "xenbr0" as
a choice for the "Shared physical device" option.

5.) Shutdown the virtual machine.

6.) Apply updates with yum (yum -y update). 

7.) Reboot

8.) Start virt-manager 

9.) Go through the dialogs to create a virtual machine. On the "Connect to host
network" dialog, virt-manager will fail to detect and display "xenbr0" as a
choice "for the "Shared physical device" option. 

10.) In a seperate terminal run brctl to see if "xenbr0" seems to exist and is
set up.

11.) virt-manager won't allow you to contine so cancel it and check for errors
in /root/.virt-manager/virt-manager.log

Actual results:

    Nothing is listed.  Empty select list.

Expected results:

    To see "xenbr0" listed as a choice to choose.

Additional info:

Relevant logs and command output.

brctl show displays "xenbr0"

   root@godzilla ~]# brctl show
   bridge name     bridge id               STP enabled     interfaces
   virbr0          8000.000000000000       no
   xenbr0          8000.feffffffffff       no              peth0
                                                           vif0.0


[root@godzilla ~]# cat /root/.virt-manager/virt-manager.log 
Fri, 07 Mar 2008 13:42:55 ERROR    Unable to connect to HAL to list network
devices: '%s'dbus_bindings.DBusException A security policy in place prevents
this sender from sending this message to this recipient, see message bus
configuration file (rejected message had interface "(unset)" member
"QueryCapability" error name "(unset)" destination "org.freedesktop.Hal")
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 104, in
detect_network_devices
    self._device_added(path)
  File "/usr/share/virt-manager/virtManager/connection.py", line 115, in
_device_added
    if obj.QueryCapability("net"):
  File "/usr/lib64/python2.4/site-packages/dbus/proxies.py", line 25, in __call__
    ret = self._proxy_method (*args, **keywords)
  File "/usr/lib64/python2.4/site-packages/dbus/proxies.py", line 102, in __call__
    reply_message = self._connection.send_with_reply_and_block(message, timeout)
  File "dbus_bindings.pyx", line 455, in
dbus_bindings.Connection.send_with_reply_and_block
DBusException: A security policy in place prevents this sender from sending this
message to this recipient, see message bus configuration file (rejected message
had interface "(unset)" member "QueryCapability" error name "(unset)"
destination "org.freedesktop.Hal")

Fri, 07 Mar 2008 13:42:55 WARNING  Unable to resolve local hostname for machine
Fri, 07 Mar 2008 13:42:58 ERROR    Unable to connect to HAL to list cdrom
volumes: 'A security policy in place prevents this sender from sending this
message to this recipient, see message bus configuration file (rejected message
had interface "(unset)" member "GetPropertyBoolean" error name "(unset)"
destination "org.freedesktop.Hal")'
[root@godzilla ~]# 

Looks like a dbus policy issue.

Here are logs of the packages applied in the update step above.

/var/log/up2date

[Fri Mar  7 12:48:23 2008] rhn_register Registered login info.
[Fri Mar  7 12:48:36 2008] rhn_register Registered system.
[Fri Mar  7 12:48:36 2008] rhn_register Wrote system id to disk.
[Fri Mar  7 12:48:37 2008] rhn_register Sent hardware profile.
[Fri Mar  7 12:48:45 2008] rhn_register Sent package list.
[Fri Mar  7 12:48:45 2008] rhn_register updating login info
[Fri Mar  7 12:48:45 2008] rhn_register logging into up2date server
[Fri Mar  7 12:48:46 2008] rhn_register successfully retrieved authentication
token from up2date server
[Fri Mar  7 12:56:40 2008] up2date logging into up2date server
[Fri Mar  7 12:56:41 2008] up2date successfully retrieved authentication token
from up2date server
[Fri Mar  7 13:15:26 2008] up2date Adding packages to package profile:
['kernel-xen-2.6.18-53.1.14.el5', 'autofs-5.0.1-0.rc2.55.el5.3',
'cairo-1.2.4-3.el5_1', 'cairo-1.2.4-3.el5_1', 'cups-1.2.4-1
1.14.el5_1.4', 'cups-libs-1.2.4-11.14.el5_1.4', 'cups-libs-1.2.4-11.14.el5_1.4',
'dbus-1.0.0-6.3.el5_1', 'dbus-1.0.0-6.3.el5_1',
'device-mapper-multipath-0.4.7-12.el5_1.2', 'e2fsprogs-1.39-10.el5
_1.1', 'e2fsprogs-libs-1.39-10.el5_1.1', 'e2fsprogs-libs-1.39-10.el5_1.1',
'firefox-1.5.0.12-11.el5_1', 'firefox-1.5.0.12-11.el5_1',
'fontconfig-2.4.1-7.el5', 'fontconfig-2.4.1-7.el5', 'glibc-2.5
-18.el5_1.1', 'glibc-2.5-18.el5_1.1', 'glibc-common-2.5-18.el5_1.1',
'hal-0.5.8.1-25.el5_1.1', 'hal-0.5.8.1-25.el5_1.1', 'kpartx-0.4.7-12.el5_1.2',
'libXfont-1.2.2-1.0.3.el5_1', 'libpng-1.2.10-7.
1.el5_0.1', 'libpng-1.2.10-7.1.el5_0.1', 'libxml2-2.6.26-2.1.2.1',
'libxml2-2.6.26-2.1.2.1', 'libxml2-python-2.6.26-2.1.2.1', 'logrotate-3.7.4-8',
'mcstrans-0.2.6-1.el5_1.1', 'mozldap-6.0.5-1.el5
', 'net-snmp-libs-5.3.1-19.el5_1.4', 'net-snmp-libs-5.3.1-19.el5_1.4',
'nscd-2.5-18.el5_1.1', 'openldap-2.3.27-8.el5_1.3', 'openldap-2.3.27-8.el5_1.3',
'openldap-clients-2.3.27-8.el5_1.3', 'pcre-
6.6-2.el5_1.7', 'perl-5.8.8-10.el5_0.2', 'python-virtinst-0.103.0-3.el5_1.1',
'rhn-check-0.4.16-2.el5_1.9', 'rhn-client-tools-0.4.16-2.el5_1.9',
'rhn-setup-0.4.16-2.el5_1.9', 'rhn-setup-gnome-0.4
.16-2.el5_1.9', 'rsh-0.17-38.el5', 'ruby-1.8.5-5.el5_1.1',
'ruby-devel-1.8.5-5.el5_1.1', 'ruby-devel-1.8.5-5.el5_1.1',
'ruby-libs-1.8.5-5.el5_1.1', 'ruby-libs-1.8.5-5.el5_1.1', 'ruby-mode-1.8.5-5
.el5_1.1', 'samba-client-3.0.25b-1.el5_1.4', 'samba-common-3.0.25b-1.el5_1.4',
'selinux-policy-2.4.6-106.el5_1.3', 'selinux-policy-targeted-2.4.6-106.el5_1.3',
'telnet-0.17-39.el5', 'tk-8.4.13-5.
el5_1.1', 'tzdata-2007k-1.el5', 'util-linux-2.13-0.45.el5_1.1',
'xorg-x11-drv-keyboard-1.1.0-3', 'xorg-x11-server-Xnest-1.1.1-48.26.el5_1.5',
'xorg-x11-server-Xorg-1.1.1-48.26.el5_1.5', 'yum-rhn-
plugin-0.5.2-5.el5_1.2']
[Fri Mar  7 13:15:26 2008] up2date Removing packages from package profile: []
[Fri Mar  7 13:20:45 2008] up2date logging into up2date server
[Fri Mar  7 13:20:46 2008] up2date successfully retrieved authentication token
from up2date server
[Fri Mar  7 13:28:07 2008] up2date logging into up2date server
[Fri Mar  7 13:28:09 2008] up2date successfully retrieved authentication token
from up2date server
[Fri Mar  7 14:28:17 2008] up2date updating login info
[Fri Mar  7 14:28:17 2008] up2date logging into up2date server
[Fri Mar  7 14:28:17 2008] up2date successfully retrieved authentication token
from up2date server


/var/log/yum.log

Mar 07 13:08:36 Updated: tzdata.noarch 2007k-1.el5
Mar 07 13:09:27 Updated: glibc-common.x86_64 2.5-18.el5_1.1
Mar 07 13:09:50 Updated: glibc.i686 2.5-18.el5_1.1
Mar 07 13:09:59 Updated: glibc.x86_64 2.5-18.el5_1.1
Mar 07 13:10:01 Updated: openldap.x86_64 2.3.27-8.el5_1.3
Mar 07 13:10:02 Updated: e2fsprogs-libs.x86_64 1.39-10.el5_1.1
Mar 07 13:10:03 Updated: libpng.x86_64 2:1.2.10-7.1.el5_0.1
Mar 07 13:10:05 Updated: libxml2.x86_64 2.6.26-2.1.2.1
Mar 07 13:10:10 Updated: ruby-libs.x86_64 1.8.5-5.el5_1.1
Mar 07 13:10:11 Updated: libXfont.x86_64 1.2.2-1.0.3.el5_1
Mar 07 13:10:16 Updated: fontconfig.x86_64 2.4.1-7.el5
Mar 07 13:10:17 Updated: libpng.i386 2:1.2.10-7.1.el5_0.1
Mar 07 13:10:21 Updated: fontconfig.i386 2.4.1-7.el5
Mar 07 13:10:26 Updated: ruby-libs.i386 1.8.5-5.el5_1.1
Mar 07 13:10:29 Updated: libxml2.i386 2.6.26-2.1.2.1
Mar 07 13:10:32 Updated: libxml2-python.x86_64 2.6.26-2.1.2.1
Mar 07 13:10:33 Updated: dbus.x86_64 1.0.0-6.3.el5_1
Mar 07 13:10:38 Updated: util-linux.x86_64 2.13-0.45.el5_1.1
Mar 07 13:10:41 Updated: hal.x86_64 0.5.8.1-25.el5_1.1
Mar 07 13:10:43 Updated: cairo.x86_64 1.2.4-3.el5_1
Mar 07 13:10:44 Updated: cups-libs.x86_64 1:1.2.4-11.14.el5_1.4
Mar 07 13:10:57 Updated: perl.x86_64 4:5.8.8-10.el5_0.2
Mar 07 13:11:00 Updated: samba-common.x86_64 3.0.25b-1.el5_1.4
Mar 07 13:11:04 Updated: dbus.i386 1.0.0-6.3.el5_1
Mar 07 13:11:05 Updated: cairo.i386 1.2.4-3.el5_1
Mar 07 13:11:06 Updated: cups-libs.i386 1:1.2.4-11.14.el5_1.4
Mar 07 13:11:07 Updated: e2fsprogs-libs.i386 1.39-10.el5_1.1
Mar 07 13:11:10 Updated: ruby.x86_64 1.8.5-5.el5_1.1
Mar 07 13:11:22 Updated: mozldap.x86_64 6.0.5-1.el5
Mar 07 13:11:24 Updated: pcre.x86_64 6.6-2.el5_1.7
Mar 07 13:11:29 Updated: tk.x86_64 8.4.13-5.el5_1.1
Mar 07 13:11:30 Updated: net-snmp-libs.x86_64 1:5.3.1-19.el5_1.4
Mar 07 13:11:31 Updated: kpartx.x86_64 0.4.7-12.el5_1.2
Mar 07 13:11:34 Updated: hal.i386 0.5.8.1-25.el5_1.1
Mar 07 13:11:36 Updated: openldap.i386 2.3.27-8.el5_1.3
Mar 07 13:11:37 Updated: net-snmp-libs.i386 1:5.3.1-19.el5_1.4
Mar 07 13:11:40 Updated: rhn-client-tools.noarch 0.4.16-2.el5_1.9
Mar 07 13:11:42 Updated: rhn-setup.noarch 0.4.16-2.el5_1.9
Mar 07 13:11:52 Updated: firefox.i386 1.5.0.12-11.el5_1
Mar 07 13:12:01 Updated: firefox.x86_64 1.5.0.12-11.el5_1
Mar 07 13:12:08 Updated: selinux-policy.noarch 2.4.6-106.el5_1.3
Mar 07 13:12:10 Updated: device-mapper-multipath.x86_64 0.4.7-12.el5_1.2
Mar 07 13:12:12 Updated: e2fsprogs.x86_64 1.39-10.el5_1.1
Mar 07 13:12:25 Updated: cups.x86_64 1:1.2.4-11.14.el5_1.4
Mar 07 13:12:26 Updated: samba-client.x86_64 3.0.25b-1.el5_1.4
Mar 07 13:12:27 Updated: xorg-x11-server-Xnest.x86_64 1.1.1-48.26.el5_1.5
Mar 07 13:12:31 Updated: autofs.x86_64 1:5.0.1-0.rc2.55.el5.3
Mar 07 13:12:33 Updated: openldap-clients.x86_64 2.3.27-8.el5_1.3
Mar 07 13:12:33 Updated: telnet.x86_64 1:0.17-39.el5
Mar 07 13:12:34 Updated: mcstrans.x86_64 0.2.6-1.el5_1.1
Mar 07 13:12:35 Updated: logrotate.x86_64 3.7.4-8
Mar 07 13:12:37 Updated: rsh.x86_64 0.17-38.el5
Mar 07 13:12:38 Updated: nscd.x86_64 2.5-18.el5_1.1
Mar 07 13:12:46 Updated: selinux-policy-targeted.noarch 2.4.6-106.el5_1.3
Mar 07 13:12:47 Updated: rhn-setup-gnome.noarch 0.4.16-2.el5_1.9
Mar 07 13:12:49 Updated: yum-rhn-plugin.noarch 0.5.2-5.el5_1.2
Mar 07 13:12:50 Updated: rhn-check.noarch 0.4.16-2.el5_1.9
Mar 07 13:12:51 Updated: ruby-devel.i386 1.8.5-5.el5_1.1
Mar 07 13:12:52 Updated: ruby-devel.x86_64 1.8.5-5.el5_1.1
Mar 07 13:12:54 Updated: python-virtinst.noarch 0.103.0-3.el5_1.1
Mar 07 13:12:55 Updated: ruby-mode.x86_64 1.8.5-5.el5_1.1
Mar 07 13:13:30 Installed: kernel-xen.x86_64 2.6.18-53.1.14.el5
Mar 07 13:13:33 Updated: xorg-x11-server-Xorg.x86_64 1.1.1-48.26.el5_1.5
Mar 07 13:13:34 Updated: xorg-x11-drv-keyboard.x86_64 1.1.0-3
Comment 1 Daniel Berrange 2008-03-07 17:45:11 EST
Yes, this is caused by the recent DBus update and the fix is being tracked in
bug  436362


*** This bug has been marked as a duplicate of 436362 ***

Note You need to log in before you can comment on or make changes to this bug.