Bug 436567 - The default library paths for Tcl 8.5 does not include /usr/lib
The default library paths for Tcl 8.5 does not include /usr/lib
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tcl (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 18:20 EST by J. Tang
Modified: 2008-03-17 10:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 10:56:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J. Tang 2008-03-07 18:20:40 EST
Description of problem:

The default search path for Tcl 8.5 does not include /usr/lib.  This is a
problem because Tk's pkgIndex.tcl is at /usr/lib/tk8.5.  For legacy code that
used the convention:

  package require Tk

the tclsh interpreter will be unable to find the Tk package.  This can be
mitigated with:

  lappend auto_path /usr/lib

prior to [package require].  However, older Tcl code should not be required to
make this change.

Note that this affects tclsh, not wish.
Comment 1 Marcela Mašláňová 2008-03-11 09:04:49 EDT
Do we forget something in our paths in tcl?
Any thoughts?
Comment 2 Wart 2008-03-11 11:27:46 EDT
I verified that this is indeed not working.  One of our Tcl patches was supposed
to fix how Tk is found, but doesn't seem to be working correctly at the moment.
 I'll take a closer look and follow up when I have more information.
Comment 3 Marcela Mašláňová 2008-03-17 10:56:45 EDT
I added another path into TCL_PACKAGE_PATH="${libdir}/tcl8.5
${prefix}/share/tcl8.5 ${libdir}/tk8.5 ${TCL_PACKAGE_PATH}"

Not sure if it's the best solution, but it's working. Tk should be the last
problematic programme, which doesn't live in tcl8.5 directory.

Note You need to log in before you can comment on or make changes to this bug.