Bug 436579 - apidocs subpackage should be noarch
apidocs subpackage should be noarch
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 19:55 EST by Jon Stanley
Modified: 2008-03-27 12:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4,0.2-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-27 12:06:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Stanley 2008-03-07 19:55:54 EST
There is no compiled code contained in the 250MB apidocs subpackage.  I maintain
a local mirror at home over a slow (1.5Mbps) link.  It would be nice if I could
just download a new apidocs once rather than twice in an rsync session (I carrry
i386 and x86_64).
Comment 1 Rex Dieter 2008-03-07 20:28:38 EST
I'm glad I'm not the only one that thinks thusly.  :)
Comment 2 Rex Dieter 2008-03-07 20:57:05 EST
In fairness, we had no idea apidocs would be so large.  Being so, makes the case
for noarch compelling.
Comment 3 Kevin Kofler 2008-03-08 09:16:36 EST
Subpackages can't be noarch.

I see only 2 solutions:
* building a second SRPM: That duplicates the SRPMs, doubles the maintainership 
effort and is overall not worth it (and 2 out of the 3 other KDE maintainers 
agreed with me when we discussed this in the meetings).
* hacks like what the kernel package is using: yuck!

I'm closing this as CANTFIX because this is impossible to fix due to a 
technical limitation in RPM.
Comment 4 Rex Dieter 2008-03-08 09:24:02 EST
Let's please discuss it (again), before concluding WONTFIX (not CANTFIX).
Comment 5 Kevin Kofler 2008-03-08 09:34:11 EST
Is the kernel package somehow special-cased or is the kernel.spec hack going to 
work for us too?

For reference, the hack is to:
ExclusiveArch: noarch i386 x86_64 ppc ppc64 ...
and to use %ifarch noarch and %ifnarch noarch everywhere.
Comment 6 Kevin Kofler 2008-03-08 09:34:56 EST
(By the way, I don't like that hack because it requires listing all the arches, 
which is a PITA each time a new secondary arch is added.)
Comment 7 Kevin Kofler 2008-03-08 09:40:28 EST
And IMHO something which is impossible to fix without ugly hacks should be 
marked NOTABUG or CANTFIX, not WONTFIX. :-)
Comment 8 Rex Dieter 2008-03-08 09:51:55 EST
kernel isn't special cased, but does require adding information to koji (I believe).

otoh, a separate srpm approach allows us not to respin -apidocs for *every*
kdelibs rebuild.

Not particularly fun, either way.
Comment 9 Jon Stanley 2008-03-27 12:06:09 EDT
noticed fixed in 4.0.2-11.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.