Bug 436615 - PCI allocation memory fails.
PCI allocation memory fails.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-08 07:10 EST by Daniel Basabe
Modified: 2008-03-11 04:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 04:34:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs and other information (130.67 KB, text/plain)
2008-03-08 07:10 EST, Daniel Basabe
no flags Details

  None (edit)
Description Daniel Basabe 2008-03-08 07:10:28 EST
Description of problem:

The last month I bought a new graphicscard for my computer.
It's a model Geforce 8400GS from Nvidia Corp.
The problem is when I want to use this hardware I can't.
The problem comes when the kernel  (2.6.24.3-12.fc8 and olders) tries to map 
the pci i/o memory.

It prints:

PCI: Cannot allocate resource region 8 of bridge 0000:00:03.0
PCI: Cannot allocate resource region 8 of bridge 0000:00:03.1
PCI: Cannot allocate resource region 8 of bridge 0000:00:03.2
PCI: Cannot allocate resource region 8 of bridge 0000:00:03.3
PCI: Cannot allocate resource region 0 of device 0000:00:00.0
PCI: Cannot allocate resource region 3 of device 0000:02:00.0
PCI: Failed to allocate mem resource #3:2000000@de000000 for 0000:02:00.0

lspci -v:

02:00.0 VGA compatible controller: nVidia Corporation GeForce 8400 GS (rev a1) 
(prog-if 00 [VGA controller])
        Flags: bus master, fast devsel, latency 0, IRQ 24
        Memory at dd000000 (32-bit, non-prefetchable) [size=16M]
        Memory at b0000000 (64-bit, prefetchable) [size=256M]
        Memory at <ignored> (64-bit, non-prefetchable)
        I/O ports at 9f00 [size=128]
        [virtual] Expansion ROM at c0000000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
        Capabilities: [68] Message Signalled Interrupts: Mask- 64bit+ 
Queue=0/0 Enable-
        Capabilities: [78] Express Endpoint, MSI 00

Xorg.0.log:

(WW) ****INVALID MEM ALLOCATION**** b: 0xce000000 e: 0xce000000 correcting^G

I attach more information of my system.


Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1.Start the system
2.
3.
  
Actual results:
I can to use X whith the generic driver nv, but nvidia driver doesn't access 
to the hardware.

Expected results:

I hope that my hardware works fine.


Additional info:

See the attachment.
Comment 1 Daniel Basabe 2008-03-08 07:10:28 EST
Created attachment 297297 [details]
logs and other information
Comment 2 Chuck Ebbert 2008-03-08 20:54:22 EST
You can try adding:

  pci=bios

to the kernel boot options.
Comment 3 Chuck Ebbert 2008-03-10 18:12:49 EDT
The adapter wants a big chunk of contiguous memory and can't get it.
Comment 4 Daniel Basabe 2008-03-11 04:34:30 EDT
I solved this issue.

The problem was the bios of the motherboard, it was buggy.
I upgraded the bios to the newest. 
Now the iomemory maps are diferent and in the lspci -v  "Memory at <ignored>"
doesn't appear.
 

Thanks for yuor help!

Note You need to log in before you can comment on or make changes to this bug.