Bug 436616 - ez-ipupdate would be started a second time on runlevel changes
Summary: ez-ipupdate would be started a second time on runlevel changes
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ez-ipupdate   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeff Layton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-08 12:14 UTC by Peter Bieringer
Modified: 2014-06-18 07:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 17:24:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Check for existing pidfile and process before starting a daemon (138 bytes, patch)
2008-03-08 12:14 UTC, Peter Bieringer
no flags Details | Diff
Check for existing pidfile and process before starting a daemon (795 bytes, patch)
2008-03-10 23:48 UTC, Jeff Layton
no flags Details | Diff

Description Peter Bieringer 2008-03-08 12:14:59 UTC
Description of problem:
Changing from runlevel 5 to 3 would start a second ez-ipupdate instance, on
start it should be checked whether instance is already running.

Version-Release number of selected component (if applicable):
ez-ipupdate-3.0.11-0.14.b8.fc7

Comment 1 Peter Bieringer 2008-03-08 12:14:59 UTC
Created attachment 297298 [details]
Check for existing pidfile and process before starting a daemon

Comment 2 Jeff Layton 2008-03-10 23:48:25 UTC
Created attachment 297536 [details]
Check for existing pidfile and process before starting a daemon

Thanks. The patch wasn't in unified diff format and seemed to put the
conditional in an odd spot. This patch is in unified diff format. Does this
look like what you had intended?

Comment 3 Peter Bieringer 2008-03-11 06:30:18 UTC
Yes, this looks good. Sorry for the not-unified diff.

Comment 4 Jeff Layton 2008-03-11 12:00:47 UTC
Thanks for the patch and the bug report. I don't have a great way to test this
at the moment, but the patch looks fairly straightforward. So...

Committed in ez-ipupdate-3.0.11-0.17.b8

...packages are building now for devel and F8. I'll let this sit in
updates-testing for a bit. Please test if you're able once they're done.

Comment 5 Fedora Update System 2008-03-11 12:29:16 UTC
ez-ipupdate-3.0.11-0.17.b8.fc8 has been submitted as an update for Fedora 8

Comment 6 Fedora Update System 2008-03-13 07:46:47 UTC
ez-ipupdate-3.0.11-0.17.b8.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ez-ipupdate'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2457

Comment 7 Fedora Update System 2008-04-22 22:37:49 UTC
ez-ipupdate-3.0.11-0.17.b8.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.