Bug 436623 - kernel update to 2.6.24.3-12.fc8 broke smb browse in nautilus
kernel update to 2.6.24.3-12.fc8 broke smb browse in nautilus
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-08 10:34 EST by Jay C. Davis
Modified: 2015-03-03 17:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-21 11:19:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay C. Davis 2008-03-08 10:34:54 EST
Description of problem:
Nautilus in browse folder mode displays "Windows Network" icon but won't browse
it. If I change the address in the location from "smb:///" to smb://<hostname>
the browse works correctly. 

Version-Release number of selected component (if applicable):
Nautilus 2.20.0
smbd version 3.0.28-0.fc8
nmbd version 3.0.28.0.fc8


How reproducible:
browse to "Windows Network" or enter "smb:///" in nautilus browser address bar

Steps to Reproduce:
(First, there must be at least one SMB host on the network)
1. Right click "Computer" icon, select "Browse Folder"
2. Double-click "Network" icon.
3. In displayed results, double-click "Windows Network"
  
Actual results:
Folder will be empty, because it doesn't find the SMB hosts.

Expected results:
Folder should show a list of SMB hosts on network

Additional info:
If you enter smb://<hostname> into the nautilus address, the shares on that host
are displayed correctly, and can be browsed. Only the smb:/// browse address
appears to be broken.
Comment 1 Tomáš Bžatek 2008-03-21 11:19:58 EDT
This is caused by firewall blocking port 445 (microsoft-ds). A predefined samba
rule is available in system-config-firewall.

Closing as NOTABUG, please feel free to reopen if problem persist with
completely disabled firewall. The smbtree utility can be useful when debugging.

Note You need to log in before you can comment on or make changes to this bug.