Bug 436639 - During process logging to my connection Wireless the alert msg SELinux Appears
During process logging to my connection Wireless the alert msg SELinux Appears
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.2
i386 Linux
low Severity medium
: rc
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-08 14:01 EST by buglife
Modified: 2008-03-10 10:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 10:06:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
setroubleshoot file (2.52 KB, text/plain)
2008-03-08 14:01 EST, buglife
no flags Details

  None (edit)
Description buglife 2008-03-08 14:01:44 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Define my connection Wireles (DHCP) throught tools RT2500 Wireless RutiiT
2. On the list I check my connection SSID example <Test>
3. Click on <Connect> 
4. Select my Profile <Test>
5. Then I click on connect Again

=> the msg from selinux (see attached file) appears
  
Actual results:


Expected results:


Additional info:
Comment 1 buglife 2008-03-08 14:01:44 EST
Created attachment 297315 [details]
setroubleshoot file
Comment 2 Daniel Walsh 2008-03-10 10:06:32 EDT
This is a leaked file descriptor from RT2500 Wireless RutiiT.  All open file
descrioptors should be closed on exec before executing the confined application.
 SELinux will just close the open file descriptors and the app should run
properly.  You should report this as a bug to the RT2500 Wireless RutiiT.  They
should call 

fcntl(fd, F_SETFD, FD_CLOEXEC) on their open descriptors.

If you want to just get rid of the AVC you can use audit2allow to write a policy
module to allow the access.

# grep dhcp /var/log/audit/audit.log | audit2allow -M mydhcp
# semodule -i mydhcp.pp

Closing wontfix since this is not our bug.

Note You need to log in before you can comment on or make changes to this bug.