Bug 436644 - Tgif does not work
Tgif does not work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tgif (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-08 14:26 EST by Arne Chr. Jorgensen
Modified: 2008-03-21 18:07 EDT (History)
0 users

See Also:
Fixed In Version: 4.1.45-6.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-21 18:07:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
locale/fonts (1.55 KB, text/plain)
2008-03-09 12:47 EDT, Arne Chr. Jorgensen
no flags Details
Screenshot (610.15 KB, image/png)
2008-03-10 07:05 EDT, Arne Chr. Jorgensen
no flags Details
rpm -qa | grep font | sort > fonts.txt Today (920 bytes, text/plain)
2008-03-10 12:34 EDT, Arne Chr. Jorgensen
no flags Details
just a recheck, did I receive an update of some packages today? I did updatedb, checked again (528 bytes, text/plain)
2008-03-11 00:16 EDT, Arne Chr. Jorgensen
no flags Details
words from the honorable master himself ;) (1.44 KB, text/plain)
2008-03-11 08:45 EDT, Arne Chr. Jorgensen
no flags Details
from the man himself ;) (992 bytes, text/plain)
2008-03-11 14:14 EDT, Arne Chr. Jorgensen
no flags Details

  None (edit)
Description Arne Chr. Jorgensen 2008-03-08 14:26:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

Description of problem:
Fonts missing in package, no readable menus, it may crash.

Version-Release number of selected component (if applicable):
tgif-4.1.45-5.fc8

How reproducible:
Always


Steps to Reproduce:
1. Install the package
2. 
3.

Actual Results:
It crash or refuse to open. Installed all sorts of fonts and tested. ( fonts it ask for is not in any supplied font-library, but including different font-libraries, can have it run, but without any readable menus. )

Expected Results:
The application should function

Additional info:
Comment 1 Mamoru TASAKA 2008-03-09 08:16:33 EDT
Would you write more verbosely what you have done (and your environment
which may be related to your issue) when the issue you see occurs
so that we can reproduce what you saw?

Also, if tgif creates core dump, would you tell us what gdb analysis says?
Comment 2 Arne Chr. Jorgensen 2008-03-09 11:04:27 EDT
1. Installed package with pirut in GNOME desktop
- I don't remember if it added some dependency
- installed without problems
2. Tried to start it by clicking /application/graphics/tgif
- nothing what so ever did happen. 
3. Checked package, then went to /usr/share/tgif and checked contents.
- in an xterm, I would execute the program, and had text output:

Warning: No type converter registered for 'String' to 'Bitmap' conversion.
Warning: Cannot set InitialFont to 'Ryumin'.

( not correct, as this is my current output. Initially these were "Error:"
- not "Warning".  The program terminated gracefully.

4. Installed many different font files, and searched them for any name 'Ryumin'
- repeated  as in step 3, supplied things like tgif --help, etc. But found
that the program started up because with these warnings instead of errors.
So, it has found some fonts that makes it start, but not the correct one.

5. As it is running at the moment:
- I can make drawings and such. The program menu does not have any characters,
only square symbols. But at the bottom status panel, I may read:
File menu - Edit menu - Layout menu....etc. while I move to cursor on the menu
bar. 
- clicking on any menu, opens the pull down menu, for example under File menu.
All sub-menus are also only square symbols. ( these are not shown at the bottom
status line - so you are totally blind. If it is open file, delete, quit or what
ever - you have now way of knowing.

6. I think the problem is pretty simple - it lacks the font file 'Ryumin' and
I recall some problem about 10 years ago, where I went and fetched the fontfile
in the developers home page. It wasn't included in the tar or zip file. 
( I used some of his initial work, as I reworked parts of it to include other
functions as an experiment ) Perhaps one may use another font file in some
default setting, but if I recall it correctly - this was difficult because it
was scalable fonts. Not sure, but think the program was under BSD, not Linux,
which could be part of the reason for the lack of fonts. 

//ARNE 




  
Comment 3 Mamoru TASAKA 2008-03-09 11:48:55 EDT
- Under what locale are you using tgif? (just type $locale)
- What does
----------------------------------------------------------------
  rpm -qa | grep font | sort
  rpm -qa | grep ghostscript | sort
----------------------------------------------------------------
  return?
- Would you take a screenshot of tgif when the error happens?
Comment 4 Arne Chr. Jorgensen 2008-03-09 12:47:11 EDT
Created attachment 297366 [details]
locale/fonts
Comment 5 Arne Chr. Jorgensen 2008-03-09 13:00:42 EDT
Sorry, I cannot recall how to make a screenshot - perhaps I need to install
something. ( -Would you take a screenshot of tgif when the error happens ? - "when
the error happens" is not correct. It simply don't start up without fonts, which
is how it is suppose to. This is a simple packaging error, in which the font file
is missing )
Comment 6 Arne Chr. Jorgensen 2008-03-09 13:25:15 EDT
This is a sidetrack, unrelated to this bug:
-------------------------------------------
On fedora-test-list@redhat.com, I am collecting some info as to ways this
processing could be done easier. If have time for it, I could mail me your
opinion, and tell me how I could improve in my reporting. ( I need to improve,
so don't be afraid to voice your opinion ;)
Comment 7 Arne Chr. Jorgensen 2008-03-09 13:26:59 EDT
Damn - I sure did spell and express badly, huh ? ;)
Comment 8 Arne Chr. Jorgensen 2008-03-09 14:36:30 EDT
Came to think of my old work, but unfortunatly, I did loose the project in some
disk crash. But unlike back then, the author wasn't difficult to
locate: http://bourbon.usc.edu/tgif/download.html
The font file may be found in some of these packages. ( think I used
FreeBSD version, as it wasn't ported to Linux..how many years ago could
that be ??)
Comment 9 Arne Chr. Jorgensen 2008-03-09 15:47:42 EDT
Please - don't let me confuse you. I have had a look at the site above, it's so
many years ago, so my memory may play tricks on me.  

- I did write some text in the drawing area, and went around in the menu system.
Then I came to think of the menus: - they may appear like they do, because of some
language settings, and so on. Right ?  I cannot read Japanese, but adobe seem to
have fonts by the name "Ryumin"
http://www.adobe.com/jp/support/qa/ciddown.html
Comment 10 Arne Chr. Jorgensen 2008-03-10 07:05:11 EDT
Created attachment 297414 [details]
Screenshot

An example I made. Notice lack of any pull-down menu text. You are working
in the blind. ( NOTE: program only opens like this because I included font
several
font files as described. Without it simply refuse to execute.
Comment 11 Arne Chr. Jorgensen 2008-03-10 07:11:13 EDT
I know that certain font-files, may not be included in package because of
copyright/license, but that is fonts used in the drawing area. Should not apply to
fonts for the menus.
Comment 12 Mamoru TASAKA 2008-03-10 10:49:04 EDT
Well, I will try to investigate this issue, however would you check
if you have installed rpms correctly?

Your "rpm -qa | grep font | sort" list shows some duplicate
rpm entries like
------------------------------------------------------------
libfontenc-1.0.4-4.fc8
libfontenc-1.0.4-4.fc8
libfontenc-devel-1.0.4-4.fc8
libXfont-1.3.1-2.fc8
libXfont-1.3.1-2.fc8
libXfontcache-1.0.4-3.fc8
libXfontcache-1.0.4-3.fc8
libXfontcache-devel-1.0.4-3.fc8
libXfontcache-devel-1.0.4-3.fc8
-------------------------------------------------------------
Comment 13 Mamoru TASAKA 2008-03-10 12:16:49 EDT
Well, I will try to some some code "clean up".....
Comment 14 Arne Chr. Jorgensen 2008-03-10 12:34:45 EDT
Created attachment 297456 [details]
rpm -qa | grep font | sort > fonts.txt  Today
Comment 15 Arne Chr. Jorgensen 2008-03-10 12:59:17 EDT
I am a bit confused by this server... anyway I have filed other bugs:
https://bugzilla.redhat.com/show_bug.cgi?id=436646
pirut/yumex do not report the same things. You pointed out to me that there
was double font files. It's either packaging, resolve depencies, or what ever.
I often get both x86_64 and i386 of the same files. I try to only select x86_64,
but then they seem to appear again. 

Other bugs:
https://bugzilla.redhat.com/show_bug.cgi?id=436689
https://bugzilla.redhat.com/show_bug.cgi?id=436635

Are you in Japan ? Could you read the font pages I mentioned ? Did it say anything ?
Comment 16 Mamoru TASAKA 2008-03-10 15:34:51 EDT
On i386 system I can correctly launch tgif in en_US locale
without any Japanese related fonts, so I doubt this is font issue.

Well, I checked the warning from gcc on x86_64 build log and actually
tgif codes contained some grammatical mistakes, which may be related
to this issue as x86_64 system has different pointer sizes compared
to i386 system (some of them are too questionable for me to find
the "correct" solution :( )

I tried to fix the gramamatical mistakes. Would you check if
the x86_64 rpm under the following URL:
http://koji.fedoraproject.org/koji/taskinfo?taskID=508766
fixes your issue? (well, I am not sure....)
Comment 17 Arne Chr. Jorgensen 2008-03-10 21:33:58 EDT
I have downloaded the following files:

build.log  
root.log   
state.log  
tgif-4.1.45-5.4.fc8.src.rpm
tgif-4.1.45-5.4.fc8.x86_64.rpm
tgif-debuginfo-4.1.45-5.4.fc8.x86_64.rpm

Installed tgif-4.1.45-5.4.fc8.x86_64.rpm, which it successfully.

1)
Launched the program from the Gnome Graphics/Tgif menu.
The program is running as before without any menu characters.
But in the message window on the right top, I read:

mainWindow ClientMessage:'_GTK_LOAD_ICONTHEMES'.
( This message was not shown previously )

2)
Launched it in a xterm window:
$ tgif
Warning: No type converter registered for 'String' to 'Bitmap' conversion.
Warning: Cannot set InitialFont to 'Ryumin'.

Message window show the Copyright note, then goes blank at the first
click in the drawing area.

3) repeated as in (1) above while writing this. Now it doesn't come
up with the message. ( maybe it only does it on the first initial 
start. Seem likely. )



Something is 'bugging' me !  I rewrote this program once, wrote 
new menus, added application, ..or let us say, I tried to do it ;)
I am not a programmer, but with enough desire..well.. 

Perhaps if I look at some of the code - I will come back to me. I have seen
this problem before !!  

I will check out a couple of things.

It can be some X11 library stuff. 
It can be some pointers as you say.

(hmm...if menu fonts are from a different library then the rest..?)

Perhaps you know of some other application that uses the same libraries. 
Would xfig be similar ?

Then keep in mind that there are something else that may indicate some
problem with this X11 driver. A few recognized the ctrl-alt-f1..trouble,
as a known bug in some drivers. This one is fearly new, as just weeks ago,
I had to resort to the drivers from ATI. This xorg driver gave me much higher
resolution then the package from ATI. ( only had 800x600 or so. Hopeless !! )
Didn't try things like Tgif then. 

Good effort Mamoru, I will check a few things ..


//ARNE
Comment 18 Arne Chr. Jorgensen 2008-03-11 00:16:39 EDT
Created attachment 297558 [details]
just a recheck, did I receive an update of some packages today?  I did updatedb, checked again

Only a check,  but perhaps you know what fonts was used in your run ?
Comment 19 Arne Chr. Jorgensen 2008-03-11 08:45:38 EDT
Created attachment 297602 [details]
words from the honorable master himself ;)
Comment 20 Arne Chr. Jorgensen 2008-03-11 09:00:38 EDT
Hi Mamoru,

Only got a few hours sleep after working around the clock. I struggle to read
what I type. As I cannot do much with the package, then I hope you may take
a look at the attachment.  Have a few other things to do, but..
Not of a clear mind right now, it would be easier to await your comments.

//ARNE
Comment 21 Arne Chr. Jorgensen 2008-03-11 14:14:26 EDT
Created attachment 297653 [details]
from the man himself ;)
Comment 22 Mamoru TASAKA 2008-03-16 13:39:39 EDT
Well, this time I removed Tgif.ad from non-Japanese locale and
add Requires for xorg-x11-fonts-75dpi. Would you try below?

http://koji.fedoraproject.org/koji/taskinfo?taskID=518677
Comment 23 Arne Chr. Jorgensen 2008-03-16 19:50:39 EDT
Hi,

Yes, tried tgif-4.1.45-5.5.fc8.x86_64.rpm, and I have menu text ;)
Did a few things, but have not done much as to check it for other possible 
problems. Did find this link:

https://bugzilla.redhat.com/show_bug.cgi?id=427806 , and my question is if
there is anything special you suggest that I should test, beside having
menu-text ?  

( have a lot to do, and it is clear that I have forgotten several details. )

Else, this was very pleasing ;)  To wander around blindly, sure wasn't that
easy.  Nice work ;) 

//ARNE

ps. in Comment #6 - well, I am new to filing and working with bugzilla, so
any comment you have regarding things I could improve, would be nice. Guess
I should have chosen something better then just "Tgif does not work".


Comment 24 Fedora Update System 2008-03-19 12:23:34 EDT
tgif-4.1.45-6.fc7 has been submitted as an update for Fedora 7
Comment 25 Fedora Update System 2008-03-19 12:25:18 EDT
tgif-4.1.45-6.fc8 has been submitted as an update for Fedora 8
Comment 26 Fedora Update System 2008-03-21 18:06:47 EDT
tgif-4.1.45-6.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Fedora Update System 2008-03-21 18:07:52 EDT
tgif-4.1.45-6.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.