Bug 436649 - Perl-Math-GMP fails selftests on ia64
Perl-Math-GMP fails selftests on ia64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Math-GMP (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora ia64 team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-03-08 15:04 EST by Doug Chapman
Modified: 2008-03-25 10:48 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.04-9.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 10:48:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2008-03-08 15:04:18 EST
Description of problem:
The tests run when building Perl-Math-GMP fails on ia64 with:


+ /usr/bin/make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0,
'blib/lib', 'blib/arch')" t/*.t
t/gmppm....# Test 278 got: "9999999999" (t/gmppm.t at line 118 fail #278)
#     Expected: "1410065407"
#  t/gmppm.t line 118 is:   print "# Tried '$try'\n" if !ok("$ans1",$ans); #
need "$ans1" due to bug
# Test 279 got: "99999999999" (t/gmppm.t at line 118 fail #279)
#     Expected: "1215752191"
# Test 280 got: "999999999999" (t/gmppm.t at line 118 fail #280)
#     Expected: "3567587327"
# Test 285 got: "9999999999" (t/gmppm.t at line 118 fail #285)
#     Expected: "1410065407"
FAILED tests 278-280, 285
	Failed 4/350 tests, 98.86% okay
Failed Test Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
t/gmppm.t                350    4   1.14%  278-280 285
Failed 1/1 test scripts, 0.00% okay. 4/350 subtests failed, 98.86% okay.
make: *** [test_dynamic] Error 255
error: Bad exit status from /var/tmp/rpm-tmp.86075 (%check)


Full build log:
http://ia64.koji.fedoraproject.org/koji/getfile?taskID=27305&name=build.log


Version-Release number of selected component (if applicable):
perl-Math-GMP-2.04-8.fc9


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Zhan, Yi 2008-03-21 04:52:39 EDT
The perl-Math-GMP-2.04-x86_64.patch, which is used to fix broken testsuite on
64-bit arches, should be applied on ia64 as well.  

So please change
    %ifarch x86_64 ppc64
    %patch0 -p0
    %endif
to
    %ifarch x86_64 ppc64 ia64
    %patch0 -p0
    %endif

Thanks, 
Yi
Comment 2 Paul Howarth 2008-03-25 10:48:51 EDT
Patch applied in perl-Math-GMP-2.04-9.fc9 and a scratch build now succeeds:

http://ia64.koji.fedoraproject.org/koji/taskinfo?taskID=39001

Note You need to log in before you can comment on or make changes to this bug.