Bug 436658 - iwl3945: bad unlock balance
iwl3945: bad unlock balance
Status: CLOSED DUPLICATE of bug 436325
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-08 15:52 EST by Adam Jackson
Modified: 2008-03-10 11:05 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 11:05:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Jackson 2008-03-08 15:52:07 EST
Description of problem:

=====================================
[ BUG: bad unlock balance detected! ]
-------------------------------------
iwl3945/1/944 is trying to release lock (rcu_read_lock) at:
[<ffffffff8818a71c>] ieee80211_scan_completed+0x1f8/0x24b [mac80211]
but there are no more locks to release!

other info that might help us debug this:
2 locks held by iwl3945/1/944:
 #0:  (iwl3945){--..}, at: [<ffffffff8104428d>] run_workqueue+0xb1/0x203
 #1:  (&priv->scan_completed){--..}, at: [<ffffffff8104428d>]
run_workqueue+0xb1/0x203

stack backtrace:
Pid: 944, comm: iwl3945/1 Not tainted 2.6.25-0.95.rc4.fc9 #1

Call Trace:
 [<ffffffff810553d4>] print_unlock_inbalance_bug+0x10c/0x11c
 [<ffffffff8100c68f>] ? restore_args+0x0/0x30
 [<ffffffff81055479>] lock_release_non_nested+0x95/0x141
 [<ffffffff8818a71c>] ? :mac80211:ieee80211_scan_completed+0x1f8/0x24b
 [<ffffffff81055669>] lock_release+0x144/0x167
 [<ffffffff8818a734>] :mac80211:ieee80211_scan_completed+0x210/0x24b
 [<ffffffff8104428d>] ? run_workqueue+0xb1/0x203
 [<ffffffff881c9054>] :iwl3945:iwl3945_bg_scan_completed+0x89/0xa8
 [<ffffffff810442d8>] run_workqueue+0xfc/0x203
 [<ffffffff881c8fcb>] ? :iwl3945:iwl3945_bg_scan_completed+0x0/0xa8
 [<ffffffff810444bf>] worker_thread+0xe0/0xf1
 [<ffffffff81047d9f>] ? autoremove_wake_function+0x0/0x38
 [<ffffffff810443df>] ? worker_thread+0x0/0xf1
 [<ffffffff81047a87>] kthread+0x49/0x76
 [<ffffffff8100cf78>] child_rip+0xa/0x12
 [<ffffffff8100c68f>] ? restore_args+0x0/0x30
 [<ffffffff81047a3e>] ? kthread+0x0/0x76
 [<ffffffff8100cf6e>] ? child_rip+0x0/0x12

Version-Release number of selected component (if applicable):

kernel-2.6.25-0.95.rc4.fc9
Comment 1 Adam Jackson 2008-03-10 09:20:54 EDT
Still there in 2.6.25-0.101.rc4.git3.fc9
Comment 2 John W. Linville 2008-03-10 11:05:27 EDT

*** This bug has been marked as a duplicate of 436325 ***

Note You need to log in before you can comment on or make changes to this bug.