Bug 436662 - Override of kMG option causes graph overlap.
Override of kMG option causes graph overlap.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mrtg (Show other bugs)
5.1
All Linux
high Severity high
: rc
: ---
Assigned To: Vitezslav Crhonek
BaseOS QE - Apps
:
Depends On:
Blocks: 499522 707188
  Show dependency treegraph
 
Reported: 2008-03-08 16:31 EST by Ray Van Dolson
Modified: 2013-04-12 15:35 EDT (History)
5 users (show)

See Also:
Fixed In Version: mrtg-2.14.5-4.el5
Doc Type: Bug Fix
Doc Text:
Previously, changing the "kMG" keyword in the MRTG configuration could cause the labels on the y-axis to overlap the main area of the generated chart. With this update, an upstream patch has been applied to address this issue, and changing the "kMG" keyword in the configuration no longer leads to the incorrect rendering of the resulting charts.
Story Points: ---
Clone Of:
: 707188 (view as bug list)
Environment:
Last Closed: 2011-11-29 05:18:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Demonstrates issue. (1.76 KB, image/png)
2008-03-08 16:31 EST, Ray Van Dolson
no flags Details
Patch to fix kMG overlap issue. (1.44 KB, patch)
2008-03-08 17:03 EST, Ray Van Dolson
no flags Details | Diff

  None (edit)
Description Ray Van Dolson 2008-03-08 16:31:15 EST
mrtg-2.14.5-2

Using the following in a graph configuration:

kMG[aggregate]: ,k,M,G,T,P

Results in the kMG values being displayed in the Y-legend incorrectly
overlapping with the graph area. Per this post:

https://lists.oetiker.ch/pipermail/mrtg/2007-April/032543.html

This appears to have been fixed in 2.15.  Would it be possible to either upgrade
to a later version or backport this fix?

Will attach image demonstrating issue.
Comment 1 Ray Van Dolson 2008-03-08 16:31:15 EST
Created attachment 297328 [details]
Demonstrates issue.
Comment 2 Ray Van Dolson 2008-03-08 17:02:16 EST
The following appears to fix the issue:

http://oss.oetiker.ch/mrtg-trac/changeset/112?format=diff&new=112
Comment 3 Ray Van Dolson 2008-03-08 17:03:30 EST
Created attachment 297334 [details]
Patch to fix kMG overlap issue.
Comment 4 Ray Van Dolson 2008-03-08 17:08:55 EST
SRPM and .spec file are here for anyone looking for a quick and obviously
unofficial fix:

http://www.bludgeon.org/~rayvd/rpms/mrtg/
Comment 5 Ray Van Dolson 2008-08-09 01:11:20 EDT
Opened SR #1849120 for this issue.
Comment 6 RHEL Product and Program Management 2009-03-26 13:01:09 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 13 Jaromir Hradilek 2011-04-04 11:13:13 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, changing the "kMG" keyword in the MRTG configuration could cause the labels on the y-axis to overlap the main area of the generated chart. With this update, an upstream patch has been applied to address this issue, and changing the "kMG" keyword in the configuration no longer leads to the incorrect rendering of the resulting charts.
Comment 23 errata-xmlrpc 2011-11-29 05:18:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1493.html

Note You need to log in before you can comment on or make changes to this bug.