Bug 436665 - sound card does not work after update to 2.6.24.3-12.fc8
sound card does not work after update to 2.6.24.3-12.fc8
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-08 17:47 EST by Johnny Walker
Modified: 2008-03-20 20:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 06:57:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached log with error -16 (57.10 KB, text/plain)
2008-03-08 17:47 EST, Johnny Walker
no flags Details
changed boot configuration (9.17 KB, image/png)
2008-03-09 09:57 EDT, Johnny Walker
no flags Details

  None (edit)
Description Johnny Walker 2008-03-08 17:47:04 EST
Description of problem:
After update (I think on 5th or 6th march 2008) sound stopped working in my
Fedora 8 x64 Xen-core installation. (Also network stopped working, but after
manual start of adapter it just worked).

I have red mark volume control and when I click on it, I get error message: No
volume control GStreamer plugins and/or devices found.

Movie player crashes when I try to start playing movie - probably due to
problems with sound.

I have Asus P5B Vista motherboard with sound card integrated on board.
Sound card detection program detects Corporation 82801H (ICH8 Family) HD Audio
Controller, module snd-hda-intel. PCM device combobox is empty.
ALSA Driver version: 1.0.15
ALSA Lib package(s): alsa-lib-1.0.15-1.fc8
ALSA Utils package(s): alsa-utils-1.0.15-1.fc8

I get error in scsconfig.log (for details see attached log):
HDA Intel: probe of 0000:00:1b.0 failed with error -16

Version-Release number of selected component (if applicable):
system-config-soundcard 2.0.6-11.fc8.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Johnny Walker 2008-03-08 17:47:04 EST
Created attachment 297341 [details]
attached log with error -16
Comment 2 Johnny Walker 2008-03-09 09:57:12 EDT
Created attachment 297356 [details]
changed boot configuration

I find out that boot configuration was changed. I have no idea why. My original
configuration was to boot with xen core. And it was changed (by update?) to
2.6.24.3-12.fc8 . After booting 2.6.21.7-2.fc8xen sound works ok. It does not
work only in 2.6.24.3-12.fc8. 
So I am not sure whether it is bug or not, whether both boot configuration
should work alongside or not.
Comment 3 Martin Stransky 2008-03-10 06:57:01 EDT
Okay, moved to kernel.
Comment 4 Sylvain Pasche 2008-03-20 20:28:47 EDT
I'm not sure why this is is marked as NOTABUG, but I can see the same issue with
2.6.24 on Ubuntu: https://bugs.launchpad.net/ubuntu/+bug/194816

Note You need to log in before you can comment on or make changes to this bug.