Bug 436672 - selinux blocks eclipse launch
selinux blocks eclipse launch
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Josef Kubin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-08 21:10 EST by hal
Modified: 2008-03-09 11:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-09 11:52:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
selinux browser log message (2.71 KB, text/plain)
2008-03-08 21:10 EST, hal
no flags Details

  None (edit)
Description hal 2008-03-08 21:10:39 EST
Description of problem: When the latest Eclipse milestone is launched with Sun's
Java 6, selinux blocks it from loading libjvm.so because it requires text
relocation.

Version-Release number of selected component (if applicable):  Eclipse 3.4M5;
Sun Java 1.6.0_04 installed in /usr/local/java/jdk1.6.0_04 (owned by root)

How reproducible: always

Steps to Reproduce:
1. Install Sun Java
2. download and unpack Eclipse 3.4M5 from
http://download.eclipse.org/eclipse/downloads/
3. double-click on the eclipse executable.
  
Actual results: Eclipse launch blocked by selinux


Expected results: Successful launch


Additional info: Log information from the browser attached.
Comment 1 hal 2008-03-08 21:10:39 EST
Created attachment 297345 [details]
selinux browser log message
Comment 2 Josef Kubin 2008-03-09 11:43:26 EDT
I've tested default installation and eclipse works.

# ls -Z /usr/java/jdk1.6.0_05/jre/lib/i386/client/libjvm.so 
-rwxr-xr-x  root root system_u:object_r:textrel_shlib_t
/usr/java/jdk1.6.0_05/jre/lib/i386/client/libjvm.so

Try to relabel your filesystem:

# restorecon -Rv /usr/local/java/

OR

# touch /.autorelabel; reboot
Comment 3 Josef Kubin 2008-03-09 11:52:09 EDT
Even if I move java tree to /usr/local it is still labeled correctly

# restorecon -Rv /usr/local/java/

# ls -Z /usr/local/java/jdk1.6.0_05/jre/lib/i386/client/libjvm.so 
-rwxr-xr-x  root root system_u:object_r:textrel_shlib_t
/usr/local/java/jdk1.6.0_05/jre/lib/i386/client/libjvm.so

# rpm -q selinux-policy
selinux-policy-2.6.4-70.fc7

In case that your problem isn't solved by above steps please reopen bug.

Note You need to log in before you can comment on or make changes to this bug.